portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "dee factorial" <deefactor...@gmail.com>
Subject LDAP - null values for uniqueMember
Date Sat, 07 Apr 2007 22:01:25 GMT
I'm attempting to load the Ldif file for the setup1 of apacheds and I'm
getting errors telling me that the unique member attribute has to have a
value but everywhere I read in the jetspeed documentation says that there
has to be an empty value for the uniqueMember attribute.

#!RESULT ERROR
#!CONNECTION ldap://server.com:10389
#!DATE 2007-04-07T12:55:09.718
#!ERROR Record is invalid
dn: cn=Group2,o=sevenSeas
objectClass: top
objectClass: groupOfUniqueNames
uniqueMember:
cn: Group2

if I remove the attribute I get this error.

#!RESULT ERROR
#!CONNECTION ldap://rhythmicearth.com:10389
#!DATE 2007-04-07T14:27:14.015
#!ERROR [LDAP: error code 65 - failed to add entry cn=Group2,o=sevenSeas:
Required attributes [2.5.4.50] not found within entry cn=Group2,o=sevenSeas]
dn: cn=Group2,o=sevenSeas
objectClass: top
objectClass: groupOfUniqueNames
cn: Group2


a little about my unusual directory server.
I've gone with the embeded Apache DS because I don't want to start up
another java instance for apacheds. I've loaded the Jetspeed.schema using
the Schema generator for apacheds and I've created a configuration with the
basic attributes, Inceptors and Bootstrap Schema.

I've copied the security-spi-ldap.xml file to the jetspeed/WEB-INF/assembly
directory.

Is there any file that needs to be removed?

I've been able to log into jetspeed with admin user but the administrative
interface does not show up.

Any help would be much appreciated.
Thanks,
Dominique

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message