portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lizann Epley <ladyh...@uoblivion.com>
Subject custom portal deployment - deploymentManager bean creation error
Date Fri, 06 Jan 2006 20:49:07 GMT
Hi All,

I have been studying Jetspeed for a couple of months now. Please 
understand - I came from a MSVC++ world and am new not only to jetspeed 
but to... well.. all things apache ; )

I am working with: Tomcat 5.5.12, Jetspeed 2 (release), Maven 1.0.2, 
JDK-1_5_0_06, ant 1.6.5 on XP Pro. My props are listed below.

So far here is where I am: I have a custom portal and a customized 
install builder (multi-developer environment, otherwise would not have 
done this). The install builder seems to be working properly for 
deploying tomcat with the portal, however... When I launch Tomcat I am 
getting an error from the deployment app when it is trying to deploy the 
portlets. It appears that the portal itself is deploying - the dir 
structure is properly expanded.

Surely I have made a simple mistake as far as a property or failure to 
properly update an xml file, but I am hoping someone can give me a quick 
point in the right direction..
 It appears to be failing during the deployment of the j2-admin portlet. 
The dir structure for this portlet has only two files in the web-inf\lib 
dir (portals-bridges-jsf-1.0.jar and tomahawk-1.1.0.jar), and that's all 
that is in this context path.

----------------------------------------------------------
The Tomcat.log (using log4j) has:
ERROR Timer-0 
org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/j2-admin] 
- JetspeedContainerServlet: initialization failed for Portlet 
Application at: j2-admin
 java.lang.ClassCastException: 
org.apache.jetspeed.tools.pamanager.PortletApplicationManager
    at 
org.apache.jetspeed.container.JetspeedContainerServlet.attemptStart(JetspeedContainerServlet.java:162)
    at 
org.apache.jetspeed.container.JetspeedContainerServlet.access$200(JetspeedContainerServlet.java:52)
    at 
org.apache.jetspeed.container.JetspeedContainerServlet$1.run(JetspeedContainerServlet.java:139)
    at java.util.TimerThread.mainLoop(Timer.java:512)
    at java.util.TimerThread.run(Timer.java:462)
----------------------------------------------------------
The Tomcat console has (along with a bunch of other stuff...)
(while adding portals-bridges-velocity-1.0.jar to the classpath for 
jetspeed-layouts)
with DEBUG logging on:
org.springframework.beans.factory.BeanCreationException: Error creating 
bean with name 'deploymentManager' defined in ServletContext resource 
[/WEB-INF/assembly/deployment.xml]: Initialization of bean failed; 
nested exception is java.lang.IncompatibleClassChangeError: null

with WARN debugging on:
Exception in thread "Autodeployment File Scanner Thread" 
java.lang.IncompatibleClassChangeError at 
org.apache.jetspeed.util.descriptor.PortletApplicationWar.<init>(PortletApplicationWar.java:128)

next line indicates this call is from:
vPortletApplicationManager.startPA(PortletApplicationManager.java:349)

-------------------------------------
from my maven debug output (shows prop settings that are registering 
from root custom portal dir) - this pulls from both USER_HOME 
build.properties and my project.properties file:
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0.2

build:start:

debugProps:
debugProps:show.maven.env.props:
    [echo]
  Maven Local Home       = c:/apache/.maven
  Maven Local Repository = c:/apache/.maven/repository
  basedir                = c:\MyPortal  (from Ant)
   

debugProps:show.custom.portal.props:
    [echo]
  Custom Portal Props:
    portal home    = c:\MyPortal
    groupId        = MyCompany
    artifactId     = myPortal
    portal name    = PortalOfMine
    portal version = 3.0
    Generation Props:
      store tomcat's config file (context.xml) in       = target/portal-conf
      directory with generated and static sql scripts   = target/portal-sql
      directory to place production database in         = target/portal-db 
      target directory for the (static) webapp files    = src/webapp
      target directory for the filtered ojb config and
             jetspeed.properties file                   = target/myPortal
    DB: portal db directory                             =
   

debugProps:show.custom.portal.db.props:
    [echo]
  Production Database Properties: 
    db name   = derby
    URL       = 
jdbc:derby:c:\MyPortal/src/webapp/WEB-INF/productiondb;create=true
    user name =
    password  =
    driver    = org.apache.derby.jdbc.EmbeddedDriver
   

debugProps:show.portal.server.props:
    [echo]
  Portal Server Properties:
    server home                  = c:/apache/apache-tomcat-5.5.12
    shared directory             = 
c:/apache/apache-tomcat-5.5.12/shared/lib/
    directory for war deployment = c:/apache/apache-tomcat-5.5.12/webapps/
    autodeployment user name     = j2deployer
    autodeployment password      = j2deployer
    catalina version major       = 5
   
BUILD SUCCESSFUL
Total time: 11 seconds
Finished at: Fri Jan 06 14:53:51 EST 2006
-------------------------------------------------

My current next step to find the problem is placing more debug into the 
jetspeed source (simple logging) to try to get a better idea of what is 
missing.

Thanks for your help.




---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-user-help@portals.apache.org


Mime
View raw message