portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bettendorf, Cristian" <Cristian.Bettend...@softwareag.com>
Subject RE: Problem with Jetspeed Administration
Date Wed, 26 Mar 2003 08:38:23 GMT
I had the same problem and solved using security settings inside the psml
(here was a thread about this subject, looks that not all DB user settings
are not used in this version)

define e.g. a new security rule in the registry:

    <security-entry name="user-custom_admin-all">
        <meta-info>
            <title>Users+V,M,M,I and Admin+C</title>
            <description>Users can view and Admin have full
access.</description>
        </meta-info>
        <access action="*">
            <allow-if role="admin"
                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="java:org.apache.jetspeed.om.registry.base.BaseSecurityAllow"/>
        </access>
        <access action="view,maximize,minimize,info">
            <allow-if role="user"
                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="java:org.apache.jetspeed.om.registry.base.BaseSecurityAllow"/>
        </access>
    </security-entry>

and refer this inside the psml.

Hope this help you.

Cristian

-----Original Message-----
From: Rana Aich [mailto:rana@anshinsoft.com]
Sent: Tuesday, March 25, 2003 9:45 PM
To: Jetspeed Users List
Subject: Problem with Jetspeed Administration


Hi All,

I'm facing a typical problem in Jetspeed Administration.

I did the following steps:

(1) I logged in http://localhost:8080/jetspeed as admin/jetspeed.
(2) I navigate to Security Role Browser and for Role "User" I withdraw the
permission "Customize". i.e. My aim is, not to allow the user to customize
the Portlets.
(3) I logout and Log in as turbine/turbine (having role "user").

Result:

For all the portlets, I can see the "Customize" icon along with four
others("Info", "Maximise", "minimise","Print").
I expected that "Customise" Icon won't be visible after "Premission" for
"Customize" is withdrawn for role "user". Moreover the user "turbine"
gleefully customizes the portlet by clicking the "customise" icon.

In short I'm not seeing the desired result.

Am I missing something?

Thanks in Advance.

Rana Aich.


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-user-help@jakarta.apache.org


Mime
View raw message