portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rana Aich" <r...@anshinsoft.com>
Subject Re: Problem with Jetspeed Administration
Date Wed, 26 Mar 2003 01:40:21 GMT
Hello,

I have tried the following in the JPortal CobiJonesPortlet in *.xreg file.

    <portlet-entry name="CobiJonesPortlet" hidden="false" type="ref"
parent="Velocity" application="false">
  <security role="user"/>
  <security-ref parent="user-only"/>
        <meta-info>
            <title>The Cobi Jones Portlet</title>
            <description>Tutorial showing an Action Event Executing,
dedicated to the man Cobi</description>
        </meta-info>
        <parameter name="template" value="cobi-jones-form" hidden="true"/>
        <parameter name="action" value="portlets.CobiJonesPortletAction"
hidden="true" />
        <media-type ref="html"/>
        <category group="Jetspeed">tutorial</category>
    </portlet-entry>

And the for role "user", I have set the permission to "View", "Maximise" and
"Minimise". The permission for "Customise" and "Info" were withdrwan. So I
expect, when the user turbine/turbine logs on, the CobiJonesPorlet should
show three action-icons. However it is showing all five.

Any small hint will be appreciated.
Thanks in advance.

Rana.


----- Original Message -----
To: "Jetspeed Users List" <jetspeed-user@jakarta.apache.org>
Sent: Tuesday, March 25, 2003 12:45 PM
Subject: Problem with Jetspeed Administration


> Hi All,
>
> I'm facing a typical problem in Jetspeed Administration.
>
> I did the following steps:
>
> (1) I logged in http://localhost:8080/jetspeed as admin/jetspeed.
> (2) I navigate to Security Role Browser and for Role "User" I withdraw the
> permission "Customize". i.e. My aim is, not to allow the user to customize
> the Portlets.
> (3) I logout and Log in as turbine/turbine (having role "user").
>
> Result:
>
> For all the portlets, I can see the "Customize" icon along with four
> others("Info", "Maximise", "minimise","Print").
> I expected that "Customise" Icon won't be visible after "Premission" for
> "Customize" is withdrawn for role "user". Moreover the user "turbine"
> gleefully customizes the portlet by clicking the "customise" icon.
>
> In short I'm not seeing the desired result.
>
> Am I missing something?
>
> Thanks in Advance.
>
> Rana Aich.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jetspeed-user-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-user-help@jakarta.apache.org


Mime
View raw message