portals-jetspeed-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <da...@bluesunrise.com>
Subject Re: MS SQL Database Error
Date Tue, 07 Jan 2003 21:49:34 GMT

On Tuesday, January 7, 2003, at 05:08  AM, NLawal@iteco.com wrote:

>
> Hello,
>
> I get the following error each time I use MS SQL as my database server:
> Horrible Exception: java.lang.Error: Error in
> BasePeer.initTableSchema(TURBINE_USER): There was no DataSourceFactory
> configured for the connection default
>
> My Torque.properties is essentially as follow:
>
> torque.database.default=default
> torque.database.default.adapter=mssql
>
> ### Microsoft SQL
> torque.dsfactory.default.connection.driver = net.avenir.jdbc3.Driver
> torque.dsfactory.default.connection.url =
> jdbc:AvenirDriver://adsebiz:1433/jetspeed
> torque.dsfactory.default.connection.user =  jetspeed
> torque.dsfactory.default.connection.password = jetspeed
>
> torque.dsfactory.default.factory=org.apache.torque.dsfactory.TorqueData 
> SourceFactory
> # The number of database connections to cache per ConnectionPool  
> instance
> (specified per database)
> torque.dsfactory.default.pool.defaultMaxConnections=10
> torque.dsfactory.default.pool.maxExpiryTime=3600
> torque.dsfactory.default.pool.connectionWaitTimeout=10
>
> Any response would be highly appreciated. Thank you.
>
>
>
The settings look fine.
I tested with the Avenir driver a while back and it worked fine for me.
Unfortunately my 30 day trial is expired now.
Are you sure that that your property files were correctly deployed to  
the server?
If you have the source, try running the unit tests:

ant unittest-security-user

--
David Sean Taylor
Bluesunrise Software
david@bluesunrise.com
+01 707 773-4646




--
To unsubscribe, e-mail:   <mailto:jetspeed-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:jetspeed-user-help@jakarta.apache.org>


Mime
View raw message