portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Yang (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] [Comment Edited] (JS2-1335) failed fo build a portal
Date Thu, 24 Sep 2015 17:15:05 GMT

    [ https://issues.apache.org/jira/browse/JS2-1335?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14906667#comment-14906667
] 

Joe Yang edited comment on JS2-1335 at 9/24/15 5:14 PM:
--------------------------------------------------------

afater setting up a non-existed directory ,it works

<org.apache.jetspeed.production.database.url>jdbc:derby:/home/csi/jetexpress/derby/productiondb;create=true</org.apache.jetspeed.production.database.url>

I used to config it on an existed directory:  /home/csi/Jetspeed-2.3.0-SNAPSHOT/database/derby/productiondb,


not sure why non-existed directory works instead of existed one?


was (Author: vkjuju):
afater setting up a non-existed directory ,it works

<org.apache.jetspeed.production.database.url>jdbc:derby:/home/csi/jetexpress/derby/productiondb;create=true</org.apache.jetspeed.production.database.url>

I used to config it on an existing directory:  /home/csi/Jetspeed-2.3.0-SNAPSHOT/database/derby/productiondb,


not sure why non-existed directory works instead of existed one?

> failed fo build a portal
> ------------------------
>
>                 Key: JS2-1335
>                 URL: https://issues.apache.org/jira/browse/JS2-1335
>             Project: Jetspeed 2
>          Issue Type: Bug
>          Components: Demo Portlets
>    Affects Versions: 2.2.2
>         Environment: windows 64bit
> jetspeed 2.2.2
> Java(TM) SE Runtime Environment (build 1.8.0_60-b27)
> Java HotSpot(TM) 64-Bit Server VM (build 25.60-b23, mixed mode)
> maven: 3.3.3
>            Reporter: Joe Yang
>            Priority: Critical
>              Labels: build
>
> Faild to build project (jetexpress) :
> command:  mvn jetspeed:mvn -Dtarget=all
> error:
> [ERROR] No plugin found for prefix 'jetspeed' in the current project and in the
> plugin groups [org.apache.portals.jetspeed-2, org.apache.maven.plugins, org.code
> haus.mojo] available from the repositories [local (C:\Users\10408002\.m2\reposit
> ory), central (https://repo.maven.apache.org/maven2)] -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
> ch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please rea
> d the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/NoPluginFoundF
> orPrefixException



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message