portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DavidSeanTaylor <da...@bluesunrise.com>
Subject Re: Regarding Jetspeed migration
Date Wed, 17 Jun 2015 14:55:44 GMT

> On Jun 16, 2015, at 11:48 PM, Lalitha Bourishetty <lalitha.bourishetty@oracle.com>
wrote:
> 
> Hi Team,
> 
> I am using windows 7 and java 8. I tried to build jetexpress tutorial example portal
with maven 3.3.3 it got failed. Then tried to build with maven 3.2.1 it also got failed.
> Hence downgraded to maven 2.2.1, it got build successfully.  
> After this when we ran the project using tomcat server it is showing error as " java.lang.ClassCastException:
java.lang.String cannot be cast to java.lang.Class " .
> When downgraded to java 7 and ran again it looks fine. Here we have a doubt like cannot
we use java 8 to work with Jetspeed 2 ? Should we use only java 7  or lower version above
java 1.5 ?  Please explain these doubts.	
> 
Jetspeed 2.2.2 runs on Java 6 and Java 7 and is targeted for Tomcat 6 but should also run
fine on Tomcat 7

If you really needed to run 2.2.2 on Java 8, you’d need to recompile it and apply a small
patch to MinimalDataSource.java


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message