portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dnyaneshwar Dabhade <dnyaneshwar.Dabh...@majesco.com>
Subject RE: Issue with User Credential functionality - Jetspeed 2.2.2
Date Wed, 10 Jun 2015 15:20:47 GMT
Hello David,

Thanks for your reply.



I have created new user testjetspeed. Other admin functionalities are working fine except
Credential. Also, the ETL migration was successful in our environment.



User enabling & disabling works fine but none of the radio button functionality works.
I checked in database as well, it does not update the values for the respective field. Hope
this helps you.





[cid:image003.jpg@01D0A3BF.204813E0]



Regards,

Dnyaneshwar





-----Original Message-----
From: DavidSeanTaylor [mailto:david@bluesunrise.com]
Sent: Wednesday, June 10, 2015 8:13 PM
To: Jetspeed Developers List
Subject: Re: Issue with User Credential functionality - Jetspeed 2.2.2





> On Jun 10, 2015, at 12:46 AM, Dnyaneshwar Dabhade <dnyaneshwar.Dabhade@majesco.com<mailto:dnyaneshwar.Dabhade@majesco.com>>
wrote:

>

> Hi Team,

>

> We have a project which we are migrating from Jetspeed 2.1.3 to Jetspeed 2.2.2.  While
testing portal admin functionalities we found that below option are not working. ( These options
are part of User Crendential Section).

> 1.       active,

> 2.        expired,

> 3.        extend

> 4.       unlimited

>

> Can anyone please help if they came across such issue and found resolution or workaround
for it.



Is there supposed to be a screenshot attachment here? I don’t see it



I’ve tried the User Credentials with Jetspeed 2.3.0 (trunk prerelease) and the functionality
seemed to be working from the UI on a fresh install For example, if I disable the account
from User Administration for a user, that user cannot login and gets the message:



"This user account its password is disabled.”



Have you ran the ETL Data Migration described here for 2.1.x -> 2.2.x migrations?



https://portals.apache.org/jetspeed-2/guide-etl-migration.html



Are you seeing any error messages?

Also, these user credentials fields should be in the database in the SECURITY_CREDENTIAL table,
here is generic XML representation of the schema for that table.



Can you see if your data for these fields were migrated correctly?



<table name="SECURITY_CREDENTIAL">

    <column name="CREDENTIAL_ID" primaryKey="true" required="true" type="INTEGER"/>

    <column name="PRINCIPAL_ID" required="true" type="INTEGER"/>

    <column name="CREDENTIAL_VALUE" required="false" size="254" type="VARCHAR"/>

    <column name="TYPE" required="true" type="SMALLINT"/>

    <column name="UPDATE_ALLOWED" required="true" type="BOOLEANINT"/>

    <column name="IS_STATE_READONLY" required="true" type="BOOLEANINT"/>

    <column name="UPDATE_REQUIRED" required="true" type="BOOLEANINT"/>

    <column name="IS_ENCODED" required="true" type="BOOLEANINT"/>

    <column name="IS_ENABLED" required="true" type="BOOLEANINT"/>

    <column name="AUTH_FAILURES" required="true" type="SMALLINT"/>

    <column name="IS_EXPIRED" required="true" type="BOOLEANINT"/>

    <column name="CREATION_DATE" required="true" type="TIMESTAMP"/>

    <column name="MODIFIED_DATE" required="true" type="TIMESTAMP"/>

    <column name="PREV_AUTH_DATE" required="false" type="TIMESTAMP"/>

    <column name="LAST_AUTH_DATE" required="false" type="TIMESTAMP"/>

    <column name="EXPIRATION_DATE" required="false" type="DATE"/>

    <foreign-key foreignTable="SECURITY_PRINCIPAL" name="FK_SECURITY_CREDENTIAL_1" onDelete="cascade">

        <reference foreign="PRINCIPAL_ID" local="PRINCIPAL_ID"/>

    </foreign-key>

    <index name="IX_SECURITY_CREDENTIAL_1">

        <index-column name="PRINCIPAL_ID"/>

    </index>

</table>







---------------------------------------------------------------------

To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org<mailto:jetspeed-dev-unsubscribe@portals.apache.org>

For additional commands, e-mail: jetspeed-dev-help@portals.apache.org<mailto:jetspeed-dev-help@portals.apache.org>


Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message