portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gonzalo Aguilar Delgado <gagui...@aguilardelgado.com>
Subject Re: [jira] Resolved: (JS2-1119) Impossible to log in using Jetspeed 2 and Tomcat 6.0.24
Date Mon, 08 Mar 2010 00:08:44 GMT
Ok. 

I will test this tomorrow.

Thank you guys for your great work!




El dom, 07-03-2010 a las 23:14 +0000, Ate Douma (JIRA) escribió:
> [ https://issues.apache.org/jira/browse/JS2-1119?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
> 
> Ate Douma resolved JS2-1119.
> ----------------------------
> 
>     Resolution: Fixed
> 
> Fix comitted both for 2.2.1 trunk and 2.1.4 branch
> 
> Gonzalo, please check if the latest trunk now works for you on Tomcat 6.0.24 again too.
Note: you'll have to do a full update and build of jetspeed-2.2.1-SNAPSHOT as this required
changes in jetspeed-api, jetspeed-commons and jetspeed-portal.
> 
> 
> > Impossible to log in using Jetspeed 2 and Tomcat 6.0.24
> > -------------------------------------------------------
> >
> >                 Key: JS2-1119
> >                 URL: https://issues.apache.org/jira/browse/JS2-1119
> >             Project: Jetspeed 2
> >          Issue Type: Bug
> >          Components: Components Core
> >    Affects Versions: 2.1.3, 2.2.1
> >         Environment: Linux Ubuntu Lucid Lynx - Tomcat 6.0.24-2 - Java 1.5 and 1.6
> >            Reporter: Gonzalo Aguilar
> >            Assignee: Ate Douma
> >             Fix For: 2.1.4, 2.2.1
> >
> >
> > Jetspeed Will not let you log in when deployed in Tomcat 6.0.24-2.
> > After inserting user and password portal will reload as usual but will not update
it's contents to reflect login success.
> > No errors are shown in logs and no clue about what's going wrong as password are
accept and normal login seems to perform normally. I traced the module to DefaultLoginModule.login()
and it works well and return success when correct user and login are used. But portal doesn't
seem to reflect the login. The problem must be other place but was not able to track it down.
> > Steps to reproduce:
> > 1.- Install Tomcat 6.0.22
> > 2.- Deploy jetspeed 2 2.2.1 with libs in place.
> > 3.- Log in as usual.
> > It will not work.
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message