portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Woonsan Ko (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] Commented: (JS2-1047) install jetspeed-installer-demo-2.2.0.jar database user oracle9i is error! why?
Date Mon, 27 Jul 2009 16:30:14 GMT

    [ https://issues.apache.org/jira/browse/JS2-1047?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12735641#action_12735641
] 

Woonsan Ko commented on JS2-1047:
---------------------------------

Hi Hongkunan, 

I've just committed all to fix this problem. Also, 'oracle10' is supported now.
By the way, if you check out the source from the trunk to build the installer, then you can
test the new installer. 
Frankly speaking, I cannot test with oracle in my local environment now. ;-)

If you want to know how to build Jetspeed-2 from the source, please refer to http://portals.apache.org/jetspeed-2/buildguide/maven-2-build.html.
For your information, you can build the installer simply like the following several commands:

$ svn checkout http://svn.apache.org/repos/asf/portals/jetspeed-2/portal/trunk jetspeed-2
$ cd jetspeed-2
$ mvn -P init clean install                                           (To build the jetspeed
maven plugin first.)
$ mvn clean install                                                      (To build all the
jetspeed components.)
$ cd jetspeed-installer
$ mvn org.apache.portals.jetspeed-2:jetspeed-mvn-maven-plugin:mvn -Dtarget=installer-demo
       (To build the installer. Please see jetspeed-installer/BUILD.txt for detail.)

You can find the installer jar file under the target folder.

Cheers,

Woonsan

> install jetspeed-installer-demo-2.2.0.jar  database user oracle9i is error! why?
> --------------------------------------------------------------------------------
>
>                 Key: JS2-1047
>                 URL: https://issues.apache.org/jira/browse/JS2-1047
>             Project: Jetspeed 2
>          Issue Type: Bug
>          Components: Other
>    Affects Versions: 2.2.0
>         Environment: os:windows xp
> jdk:1.5
> database:oracle9i
> install jetspeed-installer-demo-2.2.0.jar
>            Reporter: hongkunan
>            Assignee: Woonsan Ko
>             Fix For: 2.2.1
>
>
> when i install install jetspeed-installer-demo-2.2.0.jar use up env is error(database
use oracle9i),
> but i install it database use derby is success!
> why?
> Error Message:
> Install failed
> Error running the install,The following error occurred while executing this line:
> e:\Apache\Jetspeed-2.2\database\bulid.xml:126;Source file does not exist!
> the 126 line in build.xml content is:
> 	<sql driver="${_jdbc.driver.class}" url="${_jdbc.url}" userid="${_db.username}" password="${_db.password}"
src="${basedir}/${db.type}/drop-schema.sql" autocommit="true" onerror="continue" print="no"
output="setup.log">

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message