portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <da...@bluesunrise.com>
Subject Re: Deploy Jetspeed-2.1 in Tomcat-5.5.17
Date Tue, 08 May 2007 21:21:10 GMT

On May 8, 2007, at 6:53 AM, <anand.kulkarni@e-zest.net>  
<anand.kulkarni@e-zest.net> wrote:

> Hi,
>
> I have installed JS-2.1 successfully. Now, I want to plug JS-2.1  
> container into Tomcat 5.5.17.
>
> So, I went to \jetspeed-2.1\webapps\. Here I should find  
> jetspeed.war file and jetspeed folder. But I found only jetspeed  
> folder into webapps. So, converted this webapps/jetspeed folder  
> into jetspeed.war file.
>
> I copied this jetspeed.war file and placed it into Tomcat5.5.17 
> \webapps.
>
> Now, if I start Tomcat and visit http://localhost:8080/jetspeed/ 
> portal, it should display me the jetspeed home page. But I got the  
> error:
>
>> FATAL: Jetspeed: init() failed:
>> java.lang.InstantiationError:
>> org.apache.jetspeed.JetspeedActions
>
> The above process used to work successfully into JS-2.0, then what  
> happened in JS-2.1?
>
> Can somebody tell me how to deploy Jetspeed-2.1 inside Tomcat-5.5.17?

Look in the shared/lib directory
Are there both 2.0 and 2.1 versions of the jars there?


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message