portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timony, Michael" <Michael.Tim...@FMR.COM>
Subject Custom Portal Build Error: basedir set incorrectly
Date Wed, 17 Jan 2007 23:10:55 GMT
I updated my Jetspeed build yesterday (Jan 16th). And when I try and
build a custom portal I get the following error (my custom Portal is in
/tmp/CUSTOM_PORTAL1/portal-2):

	Embedded error: The following error occurred while executing
this line:
	java.io.FileNotFoundException: /tmp/CUSTOM_PORTAL1/build.xml (No
such file or directory)


I've tracked the problem to the creation of the custom Portal. Turning
on debugging reveals that the "basedir" isn't set correctly:

 mvn -X -e -o archetype:create
-DarchetypeGroupId=org.apache.portals.jetspeed-2
-DarchetypeArtifactId=portal-archetype -DarchetypeVersion=2.1-dev
-DgroupId=mick-2 -DartifactId=portal-2 -Dversion=1.0 1>&OUT-mick

...
[INFO] Defaulting package to group ID: mick-2
[INFO]
------------------------------------------------------------------------
----
[INFO] Using following parameters for creating Archetype:
portal-archetype:2.1-dev
[INFO]
------------------------------------------------------------------------
----
[INFO] Parameter: groupId, Value: mick-2
[INFO] Parameter: packageName, Value: mick-2
[INFO] Parameter: basedir, Value: /tmp/CUSTOM_PORTAL1
[INFO] Parameter: package, Value: mick-2
[INFO] Parameter: version, Value: 1.0
[INFO] Parameter: artifactId, Value: portal-2
...

Not sure how to debug this further.

Mick Timony



---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message