portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <da...@bluesunrise.com>
Subject Re: Jetspeed 2.1-dev build and deploy with Maven2 is OK, but mvn -P test FAILURE !
Date Mon, 15 Jan 2007 19:36:02 GMT
Javier padrĂ³n wrote:
> DEBUG: org.apache.jetspeed.components.jndi.TyrexJNDIComponent - Binding org.apache.commons.dbcp.PoolingDataSource@17fa65e
to name jdbc/jetspeed
>  INFO: org.springframework.beans.factory.xml.XmlBeanDefinitionReader - Loading XML bean
definitions from class path resource [boot/datasource.xml]
> [surefire] Tests run: 6, Failures: 0, Errors: 6, Time elapsed: 1.203 sec <<<<<<<<
FAILURE !! 
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] There are test failures.
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 1 minute 24 seconds
> [INFO] Finished at: Fri Jan 12 10:45:44 GMT 2007
> [INFO] Final Memory: 26M/51M
> [INFO] ------------------------------------------------------------------------
>  
> 
> The stranger is that although the test fails, does deploy and initiates tomcat, has this
something that to see?
> Some idea of how solving it?

The tests all passed for me recently on Maven-1 and Maven-2 builds.
It would be great if we had a continuous build setup configured to 
verify this on a nightly basis...

If you are new to Jetspeed, we recommend that you do not build from the 
source unless you are planning on making changes to the source and 
contributing back, or just trying to understand it, as building Jetspeed 
requires a good working understanding of either Maven-1 or Maven-2. At 
times, it seems that we seem to spend more time supporting the build 
than other issues.

Have you tried out our 'standard' integration method for custom builds 
described here:

http://portals.apache.org/tutorials/jetspeed-2/index.html

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message