portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Boss" <baron.muenhau...@googlemail.com>
Subject BUG: Portal Site Manager (NullPointerException)
Date Thu, 14 Sep 2006 10:07:12 GMT
Hi,

I have added by means of the Portal Site Manager new page in a portal.
I have edited page and have added in it a fragment:

<?xml version="1.0" encoding="UTF-8"?>
<page id="/Public/mifa.psml" hidden="false" version="1.0">
    <title>mifa</title>
    <short-title>mifa</short-title>
    <defaults layout-decorator="tigris" portlet-decorator="tigris"/>
    <fragment id="P-10d92fc2c13-10000" type="layout" name="jetspeed-
layouts::VelocityTwoColumns">

<fragment id="P-10d92fc2c13-10001" type="portlet" name="demo::IFramePortlet"
decorator="gray-gradient-noborder">
   <property layout="TwoColumns" name="row" value="3" />
    <property layout="TwoColumns" name="column" value="0" />
<security-constraint>
<roles>admin</roles>
<permissions>view</permissions>
</security-constraint>
  </fragment>
</fragment>
</page>

After reload of tomcat the new page did not show. Also the Portal Site
Browser has given out a Exception:
(Portlet is Not Available: j2-admin::PortalSiteBrowser
Reason: Provider org.apache.xerces.jaxp.SAXParserFactoryImpl could not be
instantiated: java.lang.NullPointerException)

javax.xml.parsers.FactoryConfigurationError: Provider
org.apache.xerces.jaxp.SAXParserFactoryImpl could not be instantiated:
java.lang.NullPointerException
        at javax.xml.parsers.SAXParserFactory.newInstance(
SAXParserFactory.java:113)
        at
org.apache.jetspeed.page.document.psml.CastorFileSystemDocumentHandler.unmarshallDocument
(CastorFileSystemDocumentHandler.java:361)
...

java.lang.NullPointerException
        at
org.apache.portals.bridges.frameworks.spring.PortletApplicationModelImpl.getTemplate
(PortletApplicationModelImpl.java:258)
        at
org.apache.portals.bridges.frameworks.GenericFrameworkPortlet.doRender(
GenericFrameworkPortlet.java:474)
        at
org.apache.portals.bridges.frameworks.GenericFrameworkPortlet.doView
...

I have stopped tomcat. Has removed a fragment from earlier created page:

<?xml version="1.0" encoding="UTF-8"?>
<page id="/Public/mifa.psml" hidden="false" version="1.0">
    <title>mifa</title>
    <short-title>mifa</short-title>
    <defaults layout-decorator="tigris" portlet-decorator="tigris"/>
    <fragment id="P-10d92fc2c13-10000" type="layout"
name="jetspeed-layouts::VelocityTwoColumns">

    </fragment>

</page>
I have started tomcat again. The Portal Site Manager has worked. Also empty
page became visible. I have again edited page and have inserted a fragment
as it has been shown right at the beginning.  After that I could see a
portlet on this page. After reload of tomcat all has repeated again.


Michael

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message