portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vlachogiannis Evangelos" <evl...@aegean.gr>
Subject RE: maven2 - jetspeed2
Date Tue, 06 Jun 2006 14:16:04 GMT
Well, after more than 10 times run "mvn" it was built successfully. 
But when I tried (about 10 times) to do "mvn -P tomcat" I got the following error. Any ideas?

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error: The following error occurred while executing this line:
C:\eclipse\workplace\j2\app-servers\build.xml:97: The following error occurred w
hile executing this line:
C:\eclipse\workplace\j2\app-servers\build.xml:153: The following error occurred
while executing this line:
C:\eclipse\workplace\j2\app-servers\tomcat-build.xml:95: The following error occ
urred while executing this line:
C:\eclipse\workplace\j2\app-servers\tomcat-build.xml:281: The following error oc
curred while executing this line:
C:\eclipse\workplace\j2\app-servers\tomcat-build.xml:372: The following error oc
curred while executing this line:
C:\eclipse\workplace\j2\app-servers\tomcat-build.xml:177: java.lang.ClassCastExc
eption: org.apache.maven.usability.MojoFailureExceptionDiagnoser
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 minute 41 seconds
[INFO] Finished at: Tue Jun 06 17:08:13 EEST 2006
[INFO] Final Memory: 24M/43M
[INFO] ------------------------------------------------------------------------

Note also that when I did mvn -P test I got:

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
[surefire] Running org.apache.jetspeed.cache.general.TestCachingInterceptors
6 ╔ΎΫΊ 2006 5:13:32 ΉΉ org.springframework.beans.factory.xml.XmlBeanDefinitionR
ader loadBeanDefinitions
INFO: Loading XML bean definitions from class path resource [org/apache/jetspee
/cache/general/cache-test.xml]
[surefire] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0,203 sec <<<<<<
< FAILURE !!
[surefire] Running org.apache.jetspeed.testhelpers.TestDatasourceHelper
[surefire] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 1,674 sec
[surefire] Running org.apache.jetspeed.testhelpers.TestOJBHelper
6 ╔ΎΫΊ 2006 5:13:34 ΉΉ org.springframework.beans.factory.support.DefaultListabl
BeanFactory preInstantiateSingletons
INFO: Pre-instantiating singletons in factory [org.springframework.beans.factor
.support.DefaultListableBeanFactory defining beans []; root of BeanFactory hier
rchy]
6 ╔ΎΫΊ 2006 5:13:34 ΉΉ org.springframework.beans.factory.support.AbstractBeanFa
tory destroySingletons
INFO: Destroying singletons in factory {org.springframework.beans.factory.suppo
t.DefaultListableBeanFactory defining beans []; root of BeanFactory hierarchy}
[surefire] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0,11 sec
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] There are test failures.
[INFO] ------------------------------------------------------------------------

> -----Original Message-----
> From: Vlachogiannis Evangelos [mailto:evlach@aegean.gr]
> Sent: Tuesday, June 06, 2006 4:49 PM
> To: Jetspeed Developers List
> Subject: RE: maven2 - jetspeed2
> 
> Ok, I have now noticed the notice about repos. I ll try again ...
> 
> > -----Original Message-----
> > From: Vlachogiannis Evangelos
> > Sent: Tuesday, June 06, 2006 4:15 PM
> > To: 'Jetspeed Developers List'
> > Subject: RE: maven2 - jetspeed2
> >
> > Hi David,
> >
> > Thnx for that.
> >
> > I am afraid we need to use maven 1 as we need the LDAP stuff.
> >
> > Anyway I have just tested maven2 (with jdk1.5) following the
> instructions on page
> > you sent. When I "mvn" I am getting error. Looking in the
> setting.xml.sample in SVN
> > I see there is no Jetspeed specific repo so should I guess that this
> is the problem?
> >
> > The error:
> > [INFO]
> ------------------------------------------------------------------------
> > [ERROR] BUILD ERROR
> > [INFO]
> ------------------------------------------------------------------------
> > [INFO] Error building POM (may not be this project's POM).
> >
> >
> > Project ID: org.apache.maven.doxia:doxia-site-renderer
> >
> > Reason: Error getting POM for
> 'org.apache.maven.doxia:doxia-site-renderer' from
> > the repository: Error transferring file
> >   org.apache.maven.doxia:doxia-site-renderer:pom:1.0-alpha-8
> >
> > from the specified remote repositories:
> >   central (http://repo1.maven.org/maven2),
> >   apache.snapshots (http://svn.apache.org/maven-snapshot-repository),
> >   snapshots (http://snapshots.maven.codehaus.org/maven2)
> >
> >
> > regards,
> > Vangelis
> >
> > > -----Original Message-----
> > > From: David Sean Taylor [mailto:david@bluesunrise.com]
> > > Sent: Monday, June 05, 2006 7:31 PM
> > > To: Jetspeed Developers List
> > > Subject: Re: maven2 - jetspeed2
> > >
> > > Vlachogiannis Evangelos wrote:
> > > > Hi list,
> > > >
> > > >
> > > >
> > > > I would like to ask if jetspeed2 can be built using maven 2. If
> yes are
> > > > there any notes for that? For example, do we need to change the
> repos?
> > > > Do we need to go mvn compile, mvn package? Then for deploying to
> tomcat
> > > > maven2 deploy seems confusing...
> > > >
> > > > Any ideas please?
> > >
> > > http://wiki.apache.org/portals/Jetspeed2/Maven2BuildSupport
> > >
> > > Randy is trying to get the Maven-2 build working with a
> > > Jetspeed-specific repo. It seems that it builds with Java 1.5, but
> we
> > > are currently stuck on a strange and challenging bug in Maven-2 with
> > > Java 1.4.
> > >
> > > Recommend building with Java 1.5. Let us know how it works for
> you...
> > >
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> > > For additional commands, e-mail:
> jetspeed-dev-help@portals.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org

Mime
View raw message