portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vlachogiannis Evangelos" <evl...@aegean.gr>
Subject RE: maven2 - jetspeed2
Date Tue, 06 Jun 2006 13:15:20 GMT
Hi David,

Thnx for that. 

I am afraid we need to use maven 1 as we need the LDAP stuff.

Anyway I have just tested maven2 (with jdk1.5) following the
instructions on page you sent. When I "mvn" I am getting error. Looking
in the setting.xml.sample in SVN I see there is no Jetspeed specific
repo so should I guess that this is the problem?

The error:
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.apache.maven.doxia:doxia-site-renderer

Reason: Error getting POM for
'org.apache.maven.doxia:doxia-site-renderer' from
the repository: Error transferring file
  org.apache.maven.doxia:doxia-site-renderer:pom:1.0-alpha-8

from the specified remote repositories:
  central (http://repo1.maven.org/maven2),
  apache.snapshots (http://svn.apache.org/maven-snapshot-repository),
  snapshots (http://snapshots.maven.codehaus.org/maven2)


regards,
Vangelis

> -----Original Message-----
> From: David Sean Taylor [mailto:david@bluesunrise.com]
> Sent: Monday, June 05, 2006 7:31 PM
> To: Jetspeed Developers List
> Subject: Re: maven2 - jetspeed2
> 
> Vlachogiannis Evangelos wrote:
> > Hi list,
> >
> >
> >
> > I would like to ask if jetspeed2 can be built using maven 2. If yes
are
> > there any notes for that? For example, do we need to change the
repos?
> > Do we need to go mvn compile, mvn package? Then for deploying to
tomcat
> > maven2 deploy seems confusing...
> >
> > Any ideas please?
> 
> http://wiki.apache.org/portals/Jetspeed2/Maven2BuildSupport
> 
> Randy is trying to get the Maven-2 build working with a
> Jetspeed-specific repo. It seems that it builds with Java 1.5, but we
> are currently stuck on a strange and challenging bug in Maven-2 with
> Java 1.4.
> 
> Recommend building with Java 1.5. Let us know how it works for you...
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message