portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Evans" <aaronmev...@gmail.com>
Subject Re: I also got the exception while start tomcat server
Date Mon, 22 May 2006 19:41:00 GMT
Yes, it is the tomcat version.  You probably did not specify your
tomcat version properly in your build.properties (you should have
specified 5.5).


On 5/21/06, Yanhua Li <yanhuaus@gmail.com> wrote:
> It works!!! Though it's very strange.
>
> I changed the file \conf\Catalina\localhost\jetspeed.xml:
>
> The original (error) (auto-generated) version has the section:
>
> --------------------------------------------------------------------------------------------
>
>  <ResourceParams name="jdbc/jetspeed">
>     <parameter>
>       <name>factory</name>
>       <value>org.apache.commons.dbcp.BasicDataSourceFactory</value>
>     </parameter>
>
>     <!-- Maximum number of dB connections in pool. Make sure you
>          configure your mysqld max_connections large enough to handle
>          all of your db connections. Set to 0 for no limit.
>          -->
>     <parameter>
>       <name>maxActive</name>
>       <value>100</value>
>     </parameter>
>
>     <!-- Maximum number of idle dB connections to retain in pool.
>          Set to 0 for no limit.
>          -->
>     <parameter>
>       <name>maxIdle</name>
>       <value>30</value>
>     </parameter>
>
>     <!-- Maximum time to wait for a dB connection to become available
>          in ms, in this example 10 seconds. An Exception is thrown if
>          this timeout is exceeded.  Set to -1 to wait indefinitely.
>          -->
>     <parameter>
>       <name>maxWait</name>
>       <value>10000</value>
>     </parameter>
>
>     <!-- HSQL dB username and password for dB connections  -->
>     <parameter>
>      <name>username</name>
>      <value>hilda</value>
>     </parameter>
>     <parameter>
>      <name>password</name>
>      <value>hilda</value>
>     </parameter>
>
>     <!-- Class name for HSQL JDBC driver -->
>     <parameter>
>        <name>driverClassName</name>
>        <value>com.mysql.jdbc.Driver</value>
>     </parameter>
>
>     <!-- The JDBC connection url for connecting to your HSQL dB.  -->
>     <parameter>
>       <name>url</name>
>       <value>jdbc:mysql://127.0.0.1:3306/jtspd</value>
>     </parameter>
>   </ResourceParams>
> --------------------------------------------------------------------------------------------
>
> And when I change them to the following format, the tomcat can startup
> successfully. Is this related to the tomcat version? I'm using tomcat 5.5.15
> .
>
> --------------------------------------------------------------------------------------------
>  <Resource name="jdbc/jetspeed" auth="Container"
>             factory="org.apache.commons.dbcp.BasicDataSourceFactory"
>             type="javax.sql.DataSource" username="hilda" password="hilda"
>             driverClassName="com.mysql.jdbc.Driver"
> url="jdbc:mysql://localhost:3306/jtspd"
>             maxActive="100" maxIdle="30" maxWait="10000"/>
> --------------------------------------------------------------------------------------------
>
> -hilda
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message