portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ate Douma <...@douma.nu>
Subject Re: org.apache.velocity.tools.generic.ToolLoader no longer in Velocity as of 1.2
Date Sun, 28 May 2006 20:11:13 GMT
Ian Nicholls wrote:
> Hi,
>  I did an update from SVN today and now I get the following error
> 
> _______________________________________________________________
> 
> 2006-05-27 12:31:54,583 [main] INFO
> org.apache.velocity.tools.view.servlet.ServletToolboxManager - Using
> config file '/WEB-INF/toolbox.xml'
> 2006-05-27 12:31:54,780 [main] ERROR
> org.apache.velocity.tools.view.servlet.ServletToolboxManager - Problem
> loading toolbox '/WEB-INF/toolbox.xml' :
> java.lang.ClassNotFoundException:
> org.apache.velocity.tools.generic.ToolLoader
> 2006-05-27 12:31:54,782 [main] ERROR
> org.apache.velocity.tools.view.servlet.ServletToolboxManager -
> java.lang.ClassNotFoundException:
> org.apache.velocity.tools.generic.ToolLoader
>        at 
> org.apache.commons.digester.Digester.createSAXException(Digester.java:2540)
>        at 
> org.apache.commons.digester.Digester.createSAXException(Digester.java:2566)
>        at 
> org.apache.commons.digester.Digester.endElement(Digester.java:1061)
>        at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown
> Source)
> 
> 
> _________________________________________________________________
> 
> I did some research into the problem and this object has been
> deprecated for a while and does not exist in the velocity-tools jar
> file I have (Version 1.2).
Jetspeed-2 itself specifies version 1.1 as dependency and that version provides the ToolLoader
class.
So it looks like you upgraded the version yourself :)
Now, if you definitely do need version 1.2, then you can stop loading the
ToolLoader by removing its entry from WEB-INF/toolbox.xml.
As I understand from Martin Dulisch, J2 seems to be able to work without it, but I haven't
tested it myself.

> 
> As A result of this I can no longer run the portal in my dev
> environment. I am trying to down grade the version ofthe
> velocity-tools to see if that fixes it without causing other problems.
Looks like you have other problems besides this one.
> 
> Ian
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message