portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ate Douma (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] Resolved: (JS2-464) Redeployment of portlets that have services defined jetspeed-portlet.xml ARE NOT updating the JETSPEED_SERVICES table with new/altered values.
Date Thu, 13 Apr 2006 14:00:03 GMT
     [ http://issues.apache.org/jira/browse/JS2-464?page=all ]
     
Ate Douma resolved JS2-464:
---------------------------

    Fix Version: 2.1
                 2.1-dev
     Resolution: Fixed

Turned out I could solve this without api change.
Well, I "cheated" of course by writing a new MultiFileChecksumHelper instead of modifying
the (single file) ChecksumHelper class. 

Anyway, this issue is now fixed. 

And: not only is jetspeed-portlet.xml now properly checked, but I also throwed web.xml into
the mix.
As some registry info is retrieved from web.xml re-registration should also be done if those
change.

Please note: as the current checksum is stored in the database and this fix will lead to a
completely different checksum, 
all existing deployed portlet applications will be re-registered once.  


> Redeployment of portlets that have services defined jetspeed-portlet.xml ARE NOT updating
the JETSPEED_SERVICES table with new/altered values.
> ----------------------------------------------------------------------------------------------------------------------------------------------
>
>          Key: JS2-464
>          URL: http://issues.apache.org/jira/browse/JS2-464
>      Project: Jetspeed 2
>         Type: Bug

>   Components: Deployment
>     Versions: 2.0-FINAL
>     Reporter: Scott T Weaver
>     Assignee: Ate Douma
>     Priority: Critical
>      Fix For: 2.1, 2.1-dev

>
> I noticed this on one of my devlopment servers when re-deploying the full portal without
wiping/recreating the database.  The MultiColumnPortlet was failing to retrieve the "DecorationsFactory"
service even though it was defined in the updated wersion of the jetspeed-portlet.xml deployment
was not updating the JETPSEED_SERVICES table.  This forced me to manually added the entry
to the table.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message