portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "yue yu (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] Created: (JS2-436) Need Urgent Help when deploy J2 on weblogic8.1
Date Wed, 07 Dec 2005 03:06:15 GMT
Need Urgent Help when deploy J2 on weblogic8.1
----------------------------------------------

         Key: JS2-436
         URL: http://issues.apache.org/jira/browse/JS2-436
     Project: Jetspeed 2
        Type: Test
    Versions: 2.0-M3    
 Environment: Os: windows xp
       My app server : weblogic8.1

       JDK version : 1.4.2.10

       DB : oracle9i

    Reporter: yue yu
    Priority: Blocker


First I copy the jetspeed direction in webapps of tomcat5 ( on tomcat5,the jetspeed working
well  )
to the weblogic ...mydomain\applications\jetspeed 

Then config following the guidance http://wiki.apache.org/portals/Jetspeed2/Fusion 
, then ,in weblogic console. deployed successfully, greatly!

       But when I open : http://localhost:7001/jetspeed/portal

       (1) I get the blank page,error is : 

you have no permission to view this page .... HTTP error 403

the back end info is :

 

<2005-12-5 下午03时42分58秒 CST> <Warning> <HTTP Session> <BEA-100061>
<Web appl

ication: ServletContext(id=29547223,name=jetspeed,context-path=/jetspeed) tried

to place a non-serializable attribute: org.apache.jetspeed.prefered.language int

o the session: DTvCF0J4pa5WzZh1WAejq45c3xQ2cFjNPTfaMzJGWKtLysWNMnHf!-1141788120!

1133768578268. This attribute will be lost upon redeployment. This message is lo

gged only once per session.>

 

(2) at the same time , when deploy security.war ,occur the error:

<2005-12-5 CST> <Error> <HTTP> <BEA-101216> <Servlet: "Jetspeed

Container" failed to preload on startup in Web application: "security".

javax.servlet.ServletException: java/lang/StringBuilder

.....

.....

<2005-12-5 CST> <Error> <HTTP> <BEA-101216> <Servlet: "Faces Se

rvlet" failed to preload on startup in Web application: "security".

javax.servlet.ServletException: No Factories configured for this Application - t

ypically this is because a context listener is not setup in your web.xml.

A typical config looks like this;

<listener>

  <listener-class>org.apache.myfaces.webapp.StartupServletContextListener</liste

ner-class>

</listener>

I don't know the first error ant the second error have something relations

 

       how can I do next , any suggects are appreciated ! !

       by the way ,I still can't open the page : http://uncommentedbytes.blogspot.com/2004/11/problem-deploying-jetspeed-2-on.html

 

                                   Thanks !



-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message