portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Watler <wat...@wispertel.net>
Subject Execution Order Dependent Registry Tests Fail
Date Wed, 30 Nov 2005 23:30:23 GMT
On my FC4 linux machine here the registry tests do not execute in the
order the tests are expecting. I was not able to use project.xml
modifications to force a test order, so perhaps these tests need to be
combined into one test?

[junit] Running
org.apache.jetspeed.components.portletentity.TestPortletEntityDAO
[junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 2.302 sec
[junit] Running
org.apache.jetspeed.components.portletregistry.direct.TestRegistryDirectPart1a
[junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 1.872 sec
[junit] Running
org.apache.jetspeed.components.portletregistry.direct.TestRegistryDirectPart2a
[junit] Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 1.662 sec
[junit] [ERROR] TEST
org.apache.jetspeed.components.portletregistry.direct.TestRegistryDirectPart2a FAILED
[junit] Running
org.apache.jetspeed.components.portletregistry.direct.TestRegistryDirectPart1b
[junit] Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 1.54 sec
[junit] [ERROR] TEST
org.apache.jetspeed.components.portletregistry.direct.TestRegistryDirectPart1b FAILED
[junit] Running
org.apache.jetspeed.components.portletregistry.TestPortletRegistryDAO
[junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 2.284 sec

I believe that these tests logically need to run in this specific order:

TestRegistryDirectPart1a
TestRegistryDirectPart1b
TestRegistryDirectPart2a

This has occurred for me after a clean pull from svn.

Randy



---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message