portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JiLong Rao <jjetsp...@sbcglobal.net>
Subject About bug-fixed: JS1-542 ---Torque OM jar generation per backend database
Date Thu, 25 Aug 2005 21:47:17 GMT

This is a question about the bug-fixed JS1-542 working on jetspeed-1.6.



We have been using jetspeed-1.5 with good connection to Oracle-8i, 9i, 
and 10g. Only problem we met initially is that it was failed when 
adding new user from admin page. The problem was solved by modifying 4 Java 
source files in org.apache.jetspeed.om.security.turbine.map package. 
The point is just to have them working with the oracle sequence.  Since 
then, the connection with oracle and “add new user” function has been 
working very well. Unfortunately, same problem comes out when we are 
trying jetspeed-1.6 now.   



I am assuming that the problem might be solved solidly by bug-fixed: 
JS1-542 using particular jetspeed-torque-om-1.6.jar per database. I 
download the one for oracle from 
http://www.bluesunrise.com/maven/jetspeed/distributions/torque-om/oracle

And replace the original jar with the new jar, then rebuild jetspeed. 
After successful deploy, the connection to oracle is fine based on 
correct settings in torque.properties.merge file. Unfortunately, it is still 
failed whenever adding new user from admin page. I then check the 
directory of %home%/.maven/repository/jetspeed/…… I find that all 
jetspeed-1.6 zip files, jar file, and pom file have been updated but the jar and 
pom files for jetspeed-torque-om-1.6 keep unchanged.  



I wonder if I did something improperly.  



Please help me by giving a step by step guide about how to do the job. 



Thanks.  



JiLong



Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message