portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weaver \(EXT\), Scott" <x_wea...@ugs.com>
Subject New development branch
Date Wed, 27 Jul 2005 14:05:26 GMT
As I was working on getting the engine unit tests to work, I noticed
there are still many places were we still need to refactor things into
Spring or make them better "citizens" so to speak.  As to avoid messing
anyone up I am going to create a new branch to commit these changes


Primary goals:

1.	Move as much into Spring as possible.
2.	Get the Engine and PortalContext into Spring (actually have this
working already)
3.	Remove as many calls to the org.apache.jetspeed.Jetspeed static
class as possible.
4.	Refactor those services that are using class.newInstance() to
use dependency injection.
5.	Implement my proposed shorter bean naming convention (email from
last week)
6.	Reduce the number of calls to the ComponentManager, again this
is solved by introducing dependency injection into those classes that
currently do not use it.


I just want to get everyone's feeling on this.  If everyone agrees I
will log this into Jira.




  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message