portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Le Strat <dlest...@yahoo.com>
Subject RE: [J2] Last Night Commit - Build Still Broken - Persistence Dependency Issue
Date Thu, 14 Jul 2005 14:16:27 GMT
Scott,

I had quite a few issues.  

1. The plugin was broken, it could not resolve some of
the dependencies versions.  See
maven-plugin/maven.xml.
2. The initMavenPlugin target was broken, something to
do with initializing with webapp and without it. 
deploy-plugin-withoutwebapp had an invalid reference
to copyPortalWebapp.
3. The j2:genapp.portal target was broken.  The
template project.xml did not have the correct
dependencies and the plugin did not have the needed
properties.
4. Some of the dependencies for portal-site, gems did
not resolve porperly.
5. The persistence component was removed, but
dependencies were still being references.

When I cleaned up my repo, cache and
portal-webapp/target this morning, to do a test with
everything clean and deployed the jetspeed app without
jetspeed-persistence (as expected).  I got an issue
with assembly when starting the engine as mentionned
in my previous email.

Regards,

David Le Strat.

--- Scott T Weaver
<scotts-jetspeed-list@binary-designs.net> wrote:

> David,
> 
> Can you tell me exactly which parts of the build
> were broke?  I had it
> running just fine yesterday before I committed.  I
> would like to know
> exactly what I broke.  There is a good chance I
> forgot something yesterday
> due to my sheer frustration with SVN.
> 
> Regards,
> -Scott
> 
> > -----Original Message-----
> > From: David Le Strat [mailto:dlestrat@yahoo.com]
> > Sent: Thursday, July 14, 2005 9:57 AM
> > To: jetspeed-dev@portals.apache.org;
> jetspeed-user@portals.apache.org
> > Subject: [J2] Last Night Commit - Build Still
> Broken - Persistence
> > Dependency Issue
> > 
> > All,
> > 
> > I decided to be thourough and do some more testing
> > this morning after spending quite a bit of time
> fixing
> > the build last night.  I cleaned all my old deps,
> my
> > plugin cache, etc.  The good news is that it
> builds
> > and all build functionality seems to be working. 
> One
> > caveat is that you now need jetspeed.version in
> > {user.home}/build.properties.  I updated
> >
>
http://www.geocities.com/dlestrat/etc/j2/buildChangeDocs.pdf
> > and have a blog entry on how to get started with
> the
> > build on http://dlsthoughts.blogspot.com.
> > 
> > The bad news is that the dependency on
> > jetspeed-persistence had to be removed, the
> component
> > was deleted.  When deploying to Tomcat, some
> Spring
> > dependencies are not resolved correctly. Please
> find
> > enclosed the logs.
> > 
> > Regards,
> > 
> > David Le Strat.
> > 
> > ________________________
> > David Le Strat
> > Blogging @ http://dlsthoughts.blogspot.com
> > 
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> protection around
> > http://mail.yahoo.com
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail:
> jetspeed-dev-help@portals.apache.org
> 
> 


________________________
David Le Strat
Blogging @ http://dlsthoughts.blogspot.com


		
____________________________________________________
Start your day with Yahoo! - make it your home page 
http://www.yahoo.com/r/hs 
 

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message