portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "R.T.H.Chin" <r.t.h.c...@tbm.tudelft.nl>
Subject Question about running applets in Jetspeed
Date Wed, 25 May 2005 10:05:17 GMT
Hi,

First of all I hope this is mailed to the correct list. I also tried to 
subscribe to the users-list but that gave me this message:
<jetspeed-user-subscribe@jakarta.apache.org>:
Sorry, no mailbox here by that name. (#5.1.1)

Anyway, I tried to make a HTML-portlet which links to a url of a webpage that contains an
applet. I made a directory in the Jetspeed(1) root and put the html page and the jars in there.
The portlet loads and shows the webpage, but the initiation of the applet fails (using the
Java plugin):

java.lang.ClassFormatError: nl/tudelft/simulation/aquarium/remote/applet/AquariumVisualizerApplet
(Bad magic number)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:157)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
... 

When running the website outside the portal the applet works fine, but inside the portal something
goes wrong, and I have no clue of how to solve this. Hope you can help me.

Thanks in advance,
Roy Chin
Delft University of Technology

	





---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message