portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anupindi, Ravikiran" <ravikiran.anupi...@bankofamerica.com>
Subject RE: Jetspeed-1 and new portlets...
Date Thu, 20 Jan 2005 17:49:12 GMT
Thanks for the response. I tried your suggestions. Now I can see my portlet,
I can select it, but when I preview the page, I don't see the portlet. The
portlet entry created in the default.psml is as follows:

********************
        <entry id="P-101913245b5-10000" parent="raviPortlet1">
            <layout position="-1" size="-1">
                <property name="column" value="0"/>
                <property name="row" value="0"/>
            </layout>
        </entry>
********************

So why am I not seeing the portlet in the page!

In the portlet 'raviPortlet1' I am extending 'GenericPortlet'. Is it a
problem? I don't see GenericPortlet.class in any of the jars came with
jetsepeed-1. I got it from trail version install of Vignette on my box
(portlet.jar).

Any ideas?

Thanks in advance.

-Ravi



-----Original Message-----
From: Mark Orciuch [mailto:mark_orciuch@ngsltd.com]
Sent: Thursday, January 20, 2005 10:56 AM
To: 'Jetspeed Developers List'
Subject: RE: Jetspeed-1 and new portlets...


You should also specify media type for your portlet. For example:

<media-type ref="html"/>

If you don't, the portlet will not be selectable from the customizer.

Best regards,

Mark Orciuch - morciuch@apache.org
Jakarta Jetspeed - Enterprise Portal in Java
http://portals.apache.org/


> -----Original Message-----
> From: Raphaël Luta [mailto:raphael@apache.org] 
> Sent: Thursday, January 20, 2005 9:48 AM
> To: Jetspeed Developers List
> Subject: Re: Jetspeed-1 and new portlets...
> 
> 
> Anupindi, Ravikiran wrote:
> 
> >Raphaël,
> >
> >Thanks for the response. I made the change as you suggested. Now the 
> >problem is, i don't see the new portlet in the list of portlets to 
> >choose from. It looks like, if there is no parent defined, 
> the portlet 
> >is not shown in the list. Is there anyway i can add the portlet 
> >manually to the page?
> >
> >  
> >
> 
> >I made a mistake my previous mail.
> >
> 
> >The correct syntax is type="instance":
> >  
> >
> Example:
> 
> <portlet-entry type="instance" name="Applications" hidden="false">
>    <security-ref parent="admin-only"/>
>    
> <classname>org.apache.jetspeed.portal.portlets.ApplicationsPor
> tlet</classname>
>    <category>admin</category>
> </portlet-entry>
> 
> -- 
> Raphaël Luta - raphael@apache.org
> Apache Portals - Enterprise Portal in Java
> http://portals.apache.org/
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org
> 
> 
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message