portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j...@apache.org
Subject [jira] Commented: (JS2-77) PicoContainer 1.0-beta5 caching and hotswap issues
Date Mon, 14 Jun 2004 14:51:10 GMT
The following comment has been added to this issue:

     Author: Scott T Weaver
    Created: Mon, 14 Jun 2004 7:50 AM
       Body:
I asked about those missing classes on the pico-user list.  They have been moved to new sub-project
called ProxyToys.


---------------------------------------------------------------------
View this comment:
  http://issues.apache.org/jira/browse/JS2-77?page=comments#action_36144

---------------------------------------------------------------------
View the issue:
  http://issues.apache.org/jira/browse/JS2-77

Here is an overview of the issue:
---------------------------------------------------------------------
        Key: JS2-77
    Summary: PicoContainer 1.0-beta5 caching and hotswap issues
       Type: Bug

     Status: Unassigned
   Priority: Critical

    Project: Jetspeed 2
 Components: 
             Components Core
   Versions:
             2.0-dev/cvs

   Assignee: 
   Reporter: Ate Douma

    Created: Mon, 14 Jun 2004 6:58 AM
    Updated: Mon, 14 Jun 2004 7:50 AM
Environment: WindowsXP SP1, J2se 1.4.2._04, Tomcat 4.1.30

Description:
I've now encountered a failing of the ComponentManager TestInterceptorAdapter.testThreadLocalDelegation()
many, many times. 
But, usually, if I run it again the problem is gone.
I guessed there must be some kind of timing issue.

What the test does is testing the instance caching of PicoContainer.
I decided to put in some debug messages inside the tested object (BaseMockComponent) its constructor.
Well, it seems the instance caching of PicoContainer isn't working as it should.
I put in the following debug message inside the constructor of BaseMockComponent:
  System.err.println(this.getClass().getName()+"("+id+","+inValue1+","+inValue2+","+threadName+")");

After I ran the test (which didn't fail this time) I got the following output:
  org.apache.jetspeed.components.BaseMockComponent(0,1,c1,main)
  org.apache.jetspeed.components.BaseMockComponent(1,2,c2,main)
  org.apache.jetspeed.components.BaseMockComponent(2,1,c1,Thread 1)
  org.apache.jetspeed.components.BaseMockComponent(3,1,c1,Thread 2)
  org.apache.jetspeed.components.BaseMockComponent(4,1,c1,Thread 3)
  org.apache.jetspeed.components.BaseMockComponent(5,1,c1,Thread 1)
  org.apache.jetspeed.components.BaseMockComponent(6,1,c1,Thread-2)
  org.apache.jetspeed.components.BaseMockComponent(7,2,c2,Thread 1)

The testcase fails if the instancecount != 3: 
  assertEquals(3, BaseMockComponent.instanceCount);
If the testcase fails on me it always reports that it found an instancecount of 4.

Because a final version 1.0 of PicoContainer is now available I decided to test that version
out to see if this bug (if it is one) was fixed.

Bummer!
A whole set of classes has been renamed and several others are dropped all together. 
Especially the Swappable interface and related functionality is gone!
The TestInterceptorAdapter makes use of the Swappable functionality so I really couldn't get
it working without having to do a large rewrite (if even possible).

What I could find out on the picocontainer website (boy, they really don't care about upgrade/migration
issues I belief, and their JIRA search is broken) gives me the impression that especially
the caching fuctionality has been moved, changed or dropped al together. 
I couldn't find it anyway. But then, I haven't looked deeply into PicoContainer yet so I may
just have been looking the wrong way.

What is quite important though is that the current codebase of J2 depends on PicoContainer
functionality which isn't supported/available anymore in the final 1.0 version (at least not
in the same way).    


---------------------------------------------------------------------
JIRA INFORMATION:
This message is automatically generated by JIRA.

If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa

If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message