portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Desire ATANGA" <data...@octo.com>
Subject RE : RE : RE : Debug with JBuilder
Date Mon, 09 Sep 2002 20:43:55 GMT
It's a known problem with catalina when it is bound to jasper. Try again
with the tomcat 3.x version that is also packaged with Jbuilder 6.

-----Message d'origine-----
De : Vlachogiannis Evangelos [mailto:evlach@aegean.gr] 
Envoyé : lundi 9 septembre 2002 19:34
À : 'Jetspeed Developers List'
Objet : RE: RE : RE : Debug with JBuilder

Thnx again! Now trying to run it I got this exception:

org.apache.jasper.JasperException: Unable to compile class for JSP
C:\development\projects\IRIS\work\index$jsp.java:69: Incompatible type for
method. Explicit cast needed to convert java.lang.Throwable to
java.lang.Exception.
            if (pageContext != null) pageContext.handlePageException(t);
                                                                     ^ 1
error

I have not change the default index.jsp. Any idea?


-----Original Message-----
From: Desire ATANGA [mailto:datanga@octo.com] 
Sent: Monday, September 09, 2002 3:36 PM
To: 'Jetspeed Developers List'
Subject: RE : RE : Debug with JBuilder


You seem to not have imported the webapp directory as a web app in your
JBuilder project. That directory contains a full configured web app.

Just for your question, here is an excerpt of the web.xml file:

[snippet]
...
    <servlet>
        <servlet-name>
           jetspeed
        </servlet-name>
        <servlet-class>
            org.apache.turbine.Turbine
        </servlet-class>

        <init-param>
            <param-name>properties</param-name>
            <param-value>
              WEB-INF/conf/TurbineResources.properties
            </param-value>            
        </init-param>
        <load-on-startup>1</load-on-startup>
    </servlet> 
...
[/snippet]

-----Message d'origine-----
De : Vlachogiannis Evangelos [mailto:evlach@aegean.gr] 
Envoyé : lundi 9 septembre 2002 12:37
À : 'Jetspeed Developers List'
Objet : RE: RE : Debug with JBuilder

Thnx for the reply. Is the JetspeedPortletFactoryService the class I need to
cofigure at the Jbuilder servlet launch uri?

-----Original Message-----
From: Desire ATANGA [mailto:datanga@octo.com] 
Sent: Monday, September 09, 2002 1:39 PM
To: 'Jetspeed Developers List'
Subject: RE : Debug with JBuilder


Hi,

You first need to generate castor registry markup Java peers that are not
present in the download package. Unjar your code and execute the "apis" ant
project before any import of your src files within JBuilder.

Hope that will help,

Desire


-----Message d'origine-----
De : Vlachogiannis Evangelos [mailto:evlach@aegean.gr] 
Envoyé : dimanche 8 septembre 2002 21:15
À : 'jetspeed-dev@jakarta.apache.org'
Objet : Debug with JBuilder

Hello,
Anyone knows how can I debug JetSpeed using Jbuilder 6? I have tried to
import src files, use library files included in src release, but errors
appears. Any help pls?

--
To unsubscribe, e-mail: <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jetspeed-dev-help@jakarta.apache.org>




--
To unsubscribe, e-mail: <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jetspeed-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail: <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jetspeed-dev-help@jakarta.apache.org>



--
To unsubscribe, e-mail: <mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jetspeed-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:
<mailto:jetspeed-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:jetspeed-dev-help@jakarta.apache.org>


Mime
View raw message