portals-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ate Douma <...@douma.nu>
Subject Re: About jetspeed 2 src building Deployment
Date Mon, 01 Mar 2010 15:12:11 GMT
On 02/28/2010 03:39 PM, 李昆 wrote:
> Hello, everybody.
> 
> I have built source code of jetspeed 2 successfully and would like to 
> deploy it to my tomcat .
> 
> I run 'mvn jetspeed:mvn -Dtarget=Demo' to deploy it, it return a Build 
> Successful to me and I also can browse the portal page in default user 
> status, but I can not login in to it using admin user or other user. I 
> mean I can not change to administration status.Except this, everything 
> seems ok.
> 
> And if I deploy my jetspeed built by source in the tomcat in the 
> Jetspeed-2 2.2.0 Installer, it can work fine.
> 
> Could somebody tell me how can I resolve this problem?
Please check the Tomcat version you're deploying against.

Different Tomcat versions in the past have (quite annoyingly) "switched" the needed JAAS authentication
configuration settings.

This configuration is defined in the portal app specific Tomcat context.xml, e.g. like $TOMCAT_HOME/conf/Catalina/localhost/jetspeed.xml.
The Realm element defined in that configuration has an attribute named "useContextClassLoader".
Recent versions of Tomcat (both 5.5.x and 6.0.x) require this attribute set with value "true",
e.g. useContextClassLoader="true".
Older versions however require the reverse of this setting, useContextClassLoader="false".

Finally, I recently tried (briefly) the latest Tomcat 6.0.24 and that turned out not to be
working anymore either with regards to JAAS
authentication :(
I haven't had time to further investigate the reason but will do so ASAP.

If you happen to deploy against Tomcat 6.0.24, please let us know as a confirmation this to
be an issue.
I also suggest for now to use Tomcat 6.0.20 then instead which is known to be working just
fine.

Regards,

Ate

> 
> Thanks.
> 
> Lee
> 
> ~~~~~~~
> 宠辱不惊,看庭前花开花落,去留无意,望天上云卷云舒。



Mime
View raw message