portals-bridges-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Woonsan Ko (JIRA)" <bridges-...@portals.apache.org>
Subject [jira] Commented: (PB-70) Groovy Bridge needs to support groovy script preferences validator and groovy script pre-286 portlet.
Date Tue, 11 Sep 2007 11:57:32 GMT

    [ https://issues.apache.org/jira/browse/PB-70?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12526434
] 

Woonsan Ko commented on PB-70:
------------------------------

More exactly speaking, the "GroovyReflector" problem can occur in the following situation:
  - a portlet application contains groovy-1.0.jar in /WEB-INF/lib/.
  - jetspeed portal application also contains groovy-1.0.jar in /WEB-INF/lib/ for some reason.

However, if each of more than one portlet application has groovy-1.0.jar and if jetspeed portal
application does not, then there's no problem.

With groovy-1.1-beta-2.jar, the above-mentioned problems does not occur any more.
See http://jira.codehaus.org/browse/GROOVY-1867 for detail.

> Groovy Bridge needs to support groovy script preferences validator and groovy script
pre-286 portlet.
> -----------------------------------------------------------------------------------------------------
>
>                 Key: PB-70
>                 URL: https://issues.apache.org/jira/browse/PB-70
>             Project: Portals Bridges
>          Issue Type: Improvement
>          Components: groovy
>    Affects Versions: 1.0.3
>            Reporter: Woonsan Ko
>            Assignee: Ate Douma
>            Priority: Minor
>             Fix For: 1.0.3
>
>         Attachments: groovy-improve-diff.zip
>
>
> We can use Groovy script to write a portlet now, but we need more.
> We should be able to write a groovy preferences validator. Also we should be able to
write a groovy script portlet which supports pre-286 header phase.
> In summary, the followings are expected:
>  - One can add a portlet preferences validator class into the portlet.xml. The class
is a wrapper class for groovy script.
>  - The wrapper class reads (read-only) preferences to find the script file and auto-refresh
mode.
>  - When auto-refresh mode is true, the modification of the validator script should be
applied instantly.
>  - Also, one can write a groovy portlet to support pre-286 header phase. Currently Jetspeed-2
API provides this interface. So the script developer implements SupportsHeaderPhase interface
of Jetspeed-2 to provide header phase.
>  - In such case, the developer can set the portlet-class to another wrapper class.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: bridges-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: bridges-dev-help@portals.apache.org


Mime
View raw message