polygene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Merlin <paulmer...@apache.org>
Subject Re: API change suggestion
Date Wed, 02 Aug 2017 11:18:47 GMT
Niclas Hedhman a écrit :
> I have found a small annoying discrepancy;
>
> interface PropertyDescriptor
> interface AssociationDescriptor
>
> shares a whole bunch of methods, which are in fact the same thing;
>
>
>     QualifiedName qualifiedName();
>
>     Type type();
>
>     AccessibleObject accessor();
>
>     boolean isImmutable();
>
>     boolean queryable();
>
>
> And in the Jooq ES, that I am working on, a great deal of duplication code
> can be avoided if they shared a common super type.
>
> I can't think of a good name for such super type, as StateDescriptor
> already exists, which is an Composite level construct. We never really have
> the equivalent of "fragments" for the
> property/association/manyassociation/namedassociation concepts, as we
> should have.
>
> We could call it StateDescriptor and rename the current StateDescriptor,
> which when I look at it doesn't have a totally solid name matching its
> purpose.
>
> WDYAT?

I stumbled upon this unfortunate modeling that leads to code duplication
in the past. Did you end up changing this?

If not then we may have to wait for 4.0 as this would be an API breaking
change, right? In that case we should create an issue and assign it to
4.0 already so we don't forget.

Cheers


Mime
View raw message