polygene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niclas Hedhman (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (POLYGENE-260) NamedAssociation.put() doesn't mark DefaultEntityState "updated"
Date Thu, 15 Jun 2017 07:45:00 GMT

    [ https://issues.apache.org/jira/browse/POLYGENE-260?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16050108#comment-16050108
] 

Niclas Hedhman commented on POLYGENE-260:
-----------------------------------------

And since all the MapEntityStore implementations doesn't croak on the new EntityTestSuite,
that seems to indicate that "UPDATED" is not supported and every LOADED entity is stored back
on UnitOfWork.complete(). This is unnecessary and seriously wasteful; Say that 1000 entities
are read to update one entity....

> NamedAssociation.put() doesn't mark DefaultEntityState "updated"
> ----------------------------------------------------------------
>
>                 Key: POLYGENE-260
>                 URL: https://issues.apache.org/jira/browse/POLYGENE-260
>             Project: Polygene
>          Issue Type: Bug
>            Reporter: Niclas Hedhman
>            Assignee: Niclas Hedhman
>             Fix For: 3.0.0
>
>
> The UPDATED is missed in DefaultEntityState if a new NamedAssociation is put(), because
if no previous value was in the Map, the method returns with false prematurely.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message