polygene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kent SĂžlvsten <kent.soelvs...@gmail.com>
Subject Re: Build system problem
Date Sun, 12 Jun 2016 08:46:14 GMT
I remember seing something similar on my machine a long time ago.

I believe I at some point used a locally modified build.gradle

test {
  maxHeapSize = "1024m" systemProperties = testProperties
  systemProperties['user.dir'] = workingDir // GRADLE-2859 ignoreFailures = false <---------------------
local change here

reports.html.enabled(true)
  afterSuite { descriptor, result ->
    if( result.resultType == TestResult.ResultType.FAILURE )
    {
      rootProject.ext.testFailures << project
    }
  }
}

Not wanting to mes up the build system (gradle is black magic to me) i
never committed the change - but you may have run into the same issue?
/Kent Den 12-06-2016 kl. 08:54 skrev Niclas Hedhman:
> Ok, so on Jenkins it reports it in the console as expected, but still not
> doing so on my local Mac... weird.
>
> Niclas
>
> On Sun, Jun 12, 2016 at 2:21 PM, Niclas Hedhman <niclas@hedhman.org> wrote:
>
>> There is currently a problem with the build system. Although there were
>> test case failures, the build did not report a problem in my local build.
>>
>> I am committing this state, to see if it is similarly not reported in
>> Jenkins... I might take a while before I manage to restore that.
>>
>> Cheers
>> --
>> Niclas Hedhman, Software Developer
>> http://zest.apache.org - New Energy for Java
>>
>
>
I

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message