polygene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mattmann, Chris A (3980)" <chris.a.mattm...@jpl.nasa.gov>
Subject Re: New restlet library
Date Sun, 27 Sep 2015 15:36:34 GMT
Ever considered using Apache CXF? That’s what we use for JAX-RS
in OODT, Tika, etc…

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Chris Mattmann, Ph.D.
Chief Architect
Instrument Software and Science Data Systems Section (398)
NASA Jet Propulsion Laboratory Pasadena, CA 91109 USA
Office: 168-519, Mailstop: 168-527
Email: chris.a.mattmann@nasa.gov
WWW:  http://sunset.usc.edu/~mattmann/
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Adjunct Associate Professor, Computer Science Department
University of Southern California, Los Angeles, CA 90089 USA
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++





-----Original Message-----
From: Paul Merlin <paul@nosphere.org>
Reply-To: "dev@zest.apache.org" <dev@zest.apache.org>
Date: Sunday, September 27, 2015 at 2:59 AM
To: "dev@zest.apache.org" <dev@zest.apache.org>
Subject: Re: New restlet library

>Niclas Hedhman a écrit :
>> Well, I don't have my laptop until Saturday.
>> But that sounds like a regular Indexing module set up problem...
>>
>> I.e. Config layer's module needs the RDF indexer's configuration type. I
>> thought that was part of the library and not my app, but I could be
>>wrong.
>> Or maybe because RDF shouldn't be hardwired as needed by the Restlet
>>lib.
>
>Well, that was how the restlet library use the layered assembly that was
>just wrong, part of the assembly was done *after* creating the app-model
>plus uses were simply not set up ... once I fixed this the app started.
>
>BUT, it stopped immediately as no HTTP service is assembled at all.
>Looks like this new restlet library is in a dangling state.
>Either some code is missing or I did miss something obvious.
>
>/Paul
>
>
>
>> Cheers
>> Niclas
>> On Sep 23, 2015 01:14, "Paul Merlin" <paul@nosphere.org> wrote:
>>
>>> Hey,
>>>
>>> I tried to run the sample app based on the new restlet library but it
>>> fails:
>>>
>>> Could not find an EntityComposite of type
>>> org.apache.zest.library.rdf.repository.NativeConfiguration in module
>>> [Indexing Module].
>>>
>>> I added a gradle task to run the sample app based on the new restlet
>>> library.
>>> You can reproduce by issueing:
>>>
>>> ./gradlew
>>> org.apache.zest.libraries:org.apache.zest.library.restlet:runSample
>>>
>>> I didn't take much time looking at it and didn't find the culprit.
>>>
>>> @Niclas: could you take a look?
>>>
>>> /Paul
>>>
>>>
>>

Mime
View raw message