polygene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandro Martini <sandro.mart...@gmail.com>
Subject Re: Unable to get content from zest git repositories
Date Mon, 20 Apr 2015 12:29:52 GMT
Just created an issue for it:

https://issues.apache.org/jira/browse/INFRA-9484

Paul, I put there even some of your description/tests of the problem :-) .

Let's update.

Bye


2015-04-20 14:22 GMT+02:00 Sandro Martini <sandro.martini@gmail.com>:
> Hi Paul,
> I think could be a problem in SSL certificates used by ASF Git ...
> I'll try to ask someone at infra and post an update later.
>
> Thanks for now.
>
> Stay well.
> Bye
>
>
> 2015-04-20 11:11 GMT+02:00 Paul Merlin <paul@nosphere.org>:
>> Hi Sandro,
>>
>> Sandro Martini a écrit :
>>> Hi all,
>>> just tried to download content from zest git repositories (
>>> https://issues.apache.org/jira/browse/ZEST-13 ), but got the following
>>> error with both:
>>>
>>> $ git pull -u
>>> fatal: unable to access 'https://git-wip-us.apache.org/repos/asf/zest-qi4j.git/'
>>> : SSL certificate problem: unable to get local issuer certificate
>>>
>>> I'm using the latest Git (version 1.9.5-preview20150319) in Windows 7 at 64 bit.
>>> The same with latest TortoiseGIT.
>>>
>>> Someone has the same problem ?
>> Yep, looks like something is wrong with the SSL certificate send by the
>> server. Some clients works, some don't. Note that Chrome accept it but
>> complains that future versions of Chrome will reject it because it miss
>> some information.
>>
>> This openssl command reproduce the error:
>>
>> echo HEAD / | openssl s_client -connect git-wip-us.apache.org:443 -quiet
>>> /dev/null
>>
>> I did not have the issue on Mac nor Linux, looks like git under windows
>> is a bit picky.
>>
>> A quick workaround is to do:
>>
>>     git config --global http.sslVerify false
>>
>> But that defeat the SSL purpose ...
>>
>> Could not find any INFRA issue about this.
>>
>> HTH
>>
>> /Paul
>>
>>
>>
>>
>>

Mime
View raw message