polygene-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nic...@apache.org
Subject [03/35] polygene-java git commit: Adding commons-validator as a dependency, and expanding what is needed from bouncycastle.
Date Sun, 28 May 2017 16:10:23 GMT
Adding commons-validator as a dependency, and expanding what is needed from bouncycastle.

Signed-off-by: niclas <niclas@hedhman.org>


Project: http://git-wip-us.apache.org/repos/asf/polygene-java/repo
Commit: http://git-wip-us.apache.org/repos/asf/polygene-java/commit/f510c1e7
Tree: http://git-wip-us.apache.org/repos/asf/polygene-java/tree/f510c1e7
Diff: http://git-wip-us.apache.org/repos/asf/polygene-java/diff/f510c1e7

Branch: refs/heads/develop
Commit: f510c1e7a034f0f7b755c97b946f488823f0667a
Parents: 105d37b
Author: niclas <niclas@hedhman.org>
Authored: Sun May 21 22:36:35 2017 +0800
Committer: niclas <niclas@hedhman.org>
Committed: Sun May 21 22:36:35 2017 +0800

----------------------------------------------------------------------
 dependencies.gradle | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/polygene-java/blob/f510c1e7/dependencies.gradle
----------------------------------------------------------------------
diff --git a/dependencies.gradle b/dependencies.gradle
index 3bab48f..aa1f22a 100644
--- a/dependencies.gradle
+++ b/dependencies.gradle
@@ -40,11 +40,12 @@ dependencies.libraries << [
 
 // Extensions, Libraries and Tools dependencies
 def bonecpVersion = '0.8.0.RELEASE'
-def bouncyVersion = '1.56'
+def bouncyVersion = '1.57'
 def cassandraClientVersion = '3.2.0'
 def codahaleMetricsVersion = '3.2.2'
 def commonsDbcpVersion = '2.1.1'
 def commonsLangVersion = '3.5'
+def commonsValidatorVersion = '1.6'
 def derbyVersion = '10.13.1.1'
 def ehcacheVersion = '3.3.1'
 def elasticsearchVersion = '5.2.2'
@@ -78,12 +79,17 @@ def spymemcachedVersion = '2.12.2'
 def velocityVersion = '1.7'
 dependencies.libraries << [
   bonecp              : "com.jolbox:bonecp:$bonecpVersion",
-  bouncy_castle       : "org.bouncycastle:bcprov-jdk15on:$bouncyVersion",
+  bouncy_castle       : [
+          "org.bouncycastle:bcprov-jdk15on:$bouncyVersion",
+          "org.bouncycastle:bcpkix-jdk15on:$bouncyVersion",
+          "org.bouncycastle:bctls-jdk15on:$bouncyVersion"
+  ],
   cassandra_client    : "com.datastax.cassandra:cassandra-driver-core:$cassandraClientVersion",
   codahale_metrics    : [ "io.dropwizard.metrics:metrics-core:$codahaleMetricsVersion",
                           "io.dropwizard.metrics:metrics-healthchecks:$codahaleMetricsVersion"
],
   commons_dbcp        : "org.apache.commons:commons-dbcp2:$commonsDbcpVersion",
   commons_lang        : "org.apache.commons:commons-lang3:$commonsLangVersion",
+  commons_validator   : "commons-validator:commons-validator:$commonsValidatorVersion",
   ehcache             : "org.ehcache:ehcache:$ehcacheVersion",
   elasticsearch       : [ "org.elasticsearch:elasticsearch:$elasticsearchVersion",
                           "org.elasticsearch.client:transport:$elasticsearchVersion",


Mime
View raw message