polygene-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From paulmer...@apache.org
Subject [19/50] [abbrv] polygene-java git commit: build: remove unnecessary default test dependencies
Date Sun, 26 Feb 2017 22:47:41 GMT
build: remove unnecessary default test dependencies


Project: http://git-wip-us.apache.org/repos/asf/polygene-java/repo
Commit: http://git-wip-us.apache.org/repos/asf/polygene-java/commit/5860c1e9
Tree: http://git-wip-us.apache.org/repos/asf/polygene-java/tree/5860c1e9
Diff: http://git-wip-us.apache.org/repos/asf/polygene-java/diff/5860c1e9

Branch: refs/heads/serialization-3.0
Commit: 5860c1e9263131ae602cc306351767ee1e330620
Parents: a74a636
Author: Paul Merlin <paulmerlin@apache.org>
Authored: Sat Feb 25 15:11:25 2017 +0100
Committer: Paul Merlin <paulmerlin@apache.org>
Committed: Sat Feb 25 15:11:25 2017 +0100

----------------------------------------------------------------------
 dependencies.gradle | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/polygene-java/blob/5860c1e9/dependencies.gradle
----------------------------------------------------------------------
diff --git a/dependencies.gradle b/dependencies.gradle
index a890bad..c8605a4 100644
--- a/dependencies.gradle
+++ b/dependencies.gradle
@@ -170,7 +170,6 @@ dependencies.libraries << [
 ]
 
 // Runtime, Test and Samples dependencies
-def antVersion = '1.9.7'
 def awaitilityVersion = '2.0.0'
 def dnsJavaVersion = '2.1.7'
 def dockerJUnitVersion = '0.3'
@@ -185,8 +184,6 @@ def mysqlVersion = '6.0.4'
 def postgresqlVersion = '9.4.1211'
 def sqliteVersion = '3.14.2.1'
 dependencies.libraries << [
-  ant               : "org.apache.ant:ant:$antVersion",
-  ant_junit         : "org.apache.ant:ant-junit:$antVersion",
   awaitility        : "org.awaitility:awaitility:$awaitilityVersion",
   derby             : "org.apache.derby:derby:$derbyVersion",
   dnsjava           : "dnsjava:dnsjava:$dnsJavaVersion",
@@ -207,10 +204,7 @@ dependencies.libraries << [
 
 // Default dependencies
 dependencies.defaultDependencies << [
-  testCompile: [ dependencies.libraries.junit,
-                 dependencies.libraries.hamcrest,
-                 dependencies.libraries.ant,
-                 dependencies.libraries.ant_junit ]
+  testImplementation: [ dependencies.libraries.junit, dependencies.libraries.hamcrest ]
 ]
 
 // Resolution rules


Mime
View raw message