polygene-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From paulmer...@apache.org
Subject polygene-java git commit: POLYGENE-223 Upgrade JClouds from 1.9.2 to 2.0.0
Date Sat, 25 Feb 2017 12:16:15 GMT
Repository: polygene-java
Updated Branches:
  refs/heads/develop 1f3b675d6 -> a74a636ec


POLYGENE-223 Upgrade JClouds from 1.9.2 to 2.0.0

Should fix the localization issues.

No more dependencies on broken GSon pom, resolution fix rule removed
from build system.


Project: http://git-wip-us.apache.org/repos/asf/polygene-java/repo
Commit: http://git-wip-us.apache.org/repos/asf/polygene-java/commit/a74a636e
Tree: http://git-wip-us.apache.org/repos/asf/polygene-java/tree/a74a636e
Diff: http://git-wip-us.apache.org/repos/asf/polygene-java/diff/a74a636e

Branch: refs/heads/develop
Commit: a74a636ec26861dba3158a0aa5898307463c23e1
Parents: 1f3b675
Author: Paul Merlin <paulmerlin@apache.org>
Authored: Sat Feb 25 13:15:50 2017 +0100
Committer: Paul Merlin <paulmerlin@apache.org>
Committed: Sat Feb 25 13:15:50 2017 +0100

----------------------------------------------------------------------
 dependencies.gradle | 7 +------
 1 file changed, 1 insertion(+), 6 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/polygene-java/blob/a74a636e/dependencies.gradle
----------------------------------------------------------------------
diff --git a/dependencies.gradle b/dependencies.gradle
index 4a00547..a890bad 100644
--- a/dependencies.gradle
+++ b/dependencies.gradle
@@ -57,7 +57,7 @@ def jacksonVersion = '2.8.5'
 def javascriptVersion = '1.7.7.1'
 def javasqlgeneratorVersion = '0.3.2'
 def jaxbApiVersion = '2.2.12'
-def jcloudsVersion = '1.9.2' // 2.0.0 exists
+def jcloudsVersion = '2.0.0'
 def jdbmVersion = '2.4'
 def jedisVersion = '2.9.0'
 def jettyVersion = '9.2.17.v20160517' // 9.3.x Tests fail!
@@ -245,11 +245,6 @@ dependencies.dependencySubstitutionSpec = { DependencySubstitution substitution,
   {
     substitution.useTarget group: dep.group, name: dep.module, version: '3'
   }
-  // GSON 2.3 POM is invalid, use 2.3.1 instead .. see https://github.com/google/gson/issues/588
-  else if( dep.group == 'com.google.code.gson' && dep.module == 'gson' &&
dep.version == '2.3' )
-  {
-    substitution.useTarget group: dep.group, name: dep.module, version: '2.3.1'
-  }
   // Findbugs Annotation is LGPL, use https://github.com/stephenc/findbugs-annotations which
is
   // Apache 2 licensed instead
   else if( dep.group == 'net.sourceforge.findbugs' && dep.module == 'annotations'
)


Mime
View raw message