poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Murphy, Mark" <murphym...@metalexmfg.com>
Subject RE: Any Idea Why Word Does not Preserve Leading or Trailing Space?
Date Thu, 16 Aug 2018 13:46:15 GMT
Maybe the space is preserved only at the end of the text in the node?

-----Original Message-----
From: Eliot Kimber [mailto:ekimber@contrext.com] 
Sent: Wednesday, August 15, 2018 4:21 PM
To: POI Users List <user@poi.apache.org>
Subject: Any Idea Why Word Does not Preserve Leading or Trailing Space?

In the DOCX I'm generating I have this pair of runs:

<w:r><w:t>If an applicant under subsection</w:t></w:r><w:r><w:t
xml:space="preserve"> 38-79</w:t></w:r>

Notice the leading space in the second run (" 38-79").

When I view this with Word for Mac (16.16) the space is not rendered.

This seems like a bug, especially since space is preserve on the w:t element.

Any idea why Word behaves this way and if there's a way to avoid it (other than merging the
two runs, which in this case have the same properties)?

This is DOCX being generated from XML source where the runs reflect separate source nodes
(in this case a text node and then an inline element).

Thanks,

Eliot
--
Eliot Kimber
http://contrext.com
 



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@poi.apache.org For additional commands, e-mail: user-help@poi.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@poi.apache.org
For additional commands, e-mail: user-help@poi.apache.org
Mime
View raw message