poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Law <David....@apconsult.de>
Subject Re: Maven repository?
Date Mon, 17 Feb 2014 07:08:16 GMT

procatively -> proactively :-)


On 16/02/2014 22:51, David Law wrote:
> ok Folks,
>
> so here's the lowdown:
>
> maven central has 2 Indices.
> One is updated near-real-time.
> The other "legacy index" is updated less often
> (the last 2 times being 2014.02.09 13:49 & 2014.02.16 12:52)
>
> No prize for guessing which one m2eclipse uses!
>
> But, rather than waiting a week, there is a workaround:
> if you know the Group Id, Artifact Id & Version, these can be 
> procatively requested.
>
>
> All the best,
> DaveLaw
>
>
> On 16/02/2014 06:35, David Law wrote:
>> Hi again Folks,
>>
>> QUESTION) is anybody out there actually able to /see/ 3.10-FINAL
>> in http://repo.maven.apache.org/maven2
>> using eclipse with m2eclipse?
>>
>> I see the following error possibilities:
>> 1) I'm doing something wrong
>>     (but what? Installing m2eclipse is straightforward enough)
>> 2) poi has been checked-in in some invalid state?
>> 3) maven has a bug?
>> 4) m2eclipse has a bug?
>>
>> Grateful for any thoughts... :-)
>>
>> All the best,
>> DaveLaw
>>
>>
>> On 14/02/2014 17:15, David Law wrote:
>>> That's a very good point Nick! :-)
>>>
>>> Thanks for the URL: I had tried to search the repo,
>>> but was redirected to http://search.maven.org/#browse
>>>
>>> So 3.10-FINAL is in the repo, but neither "Rebuild index"
>>> nor "Update Index" are working for me.
>>>
>>> Anyway, thanks again for you off-topic help.
>>> Maybe with what I now know, Google will yield a solution.
>>>
>>> Having Googled a bit, I wonder if
>>> <version>3.10-beta1</version>
>>> in
>>> http://repo.maven.apache.org/maven2/org/apache/poi/poi/maven-metadata.xml 
>>>
>>> has anything to do with it?...
>>>
>>> All the Best,
>>> DaveLaw
>>>
>>> On 14/02/2014 14:41, Nick Burch wrote:
>>>> On Fri, 14 Feb 2014, David Law wrote:
>>>>> I've installed maven using the m2eclipse plugin
>>>>> but the install doesn't seem to create a settings.xml
>>>>> & seems to just default to:
>>>>> http://repo.maven.apache.org/maven2
>>>>
>>>> http://repo.maven.apache.org/maven2/org/apache/poi/poi/3.10-FINAL/
>>>>
>>>> The files are there on that server!
>>>>
>>>> I think at this point you'll need to go and ask on the m2eclipse or 
>>>> maven users list
>>>>
>>>> Nick
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: user-unsubscribe@poi.apache.org
>>>> For additional commands, e-mail: user-help@poi.apache.org
>>>>
>>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: user-unsubscribe@poi.apache.org
>>> For additional commands, e-mail: user-help@poi.apache.org
>>>
>>>
>>
>>
>


Mime
View raw message