poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Burch <nick.bu...@alfresco.com>
Subject Re: Problems building Apache POI 3.8 on Ubuntu 10.04
Date Thu, 29 Mar 2012 10:04:19 GMT
On Thu, 29 Mar 2012, Stuart Owen wrote:
>    I get a build error when I try and build the downloaded src package for 
> 3.8. This is on Ubuntu 10.04 (LTS) with the latest updates.
>    I downloaded poi-src-3.8-20120326.tar.gz and run
>> ant clean
>> ant dist

Builds for me just fine on 10.04 with OpenJDK, and the system supplied ant 
(1.7.1), so I'm not sure what's different for you


> build.xml:412: taskdef class org.apache.xmlbeans.impl.tool.XMLBean cannot be 
> found

The jar that provides this should be downloaded automatically, and 
included on the classpath when the task is defined. Can you check that 
xmlbeans-2.3.0.jar was downloaded to your ooxml-lib directory, and it's a 
valid (non corrupt) jar file - try doing "jar tvf" on it to check it lists 
properly

Nick

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@poi.apache.org
For additional commands, e-mail: user-help@poi.apache.org


Mime
View raw message