poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simmons, Tom (GE Oil & Gas, VG)" <tom.simmo...@ge.com>
Subject Updating project from 3.7 to 3.8 beta 4
Date Thu, 15 Sep 2011 09:57:29 GMT
I need to start using the version 3.8 in my project which currently uses 3.7.  I was hoping
it would be a clean swap, but for some reason I'm getting a handful of silly errors.

XSSFReader xssfReader = new XSSFReader(pkg); - The constructor XSSFReader(OPCPackage) is undefined

cell.getColumnIndex(); - The method getColumnIndex() is undefined for the type HSSFCell -
Cell is definitely an HSSFCell

row.getCell(x++) - The method getCell(short) in the type HSSFRow is not applicable for the
arguments (int) - x confirmed as int, row as HSSFRow

I haven't found anything saying the upgrade should be anything other than a direct replacement.
 All the constructors/methods all exist according to the API.

Any ideas?


Tom

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message