poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ramon F Herrera <ra...@patriot.net>
Subject Re: Trying to edit a spreadsheet using XSSF
Date Thu, 22 Apr 2010 13:49:06 GMT
On 4/21/2010 9:18 PM, David Fisher wrote:
> Hi Ramon,
>
> For OOXML you will need more jar files. See the maven artifacts listed towards the bottom
of http://poi.apache.org/overview.html
>
> Regards,
> Dave
>


Hi David,

Thanks for you kind reply. I tried your suggestion, but unfortunately 
the problem remains. This is what I did: I added all jar files that are 
included with the distribution to my CLASSPATH:

  - poi-3.6-20091214.jar
  - poi-contrib-3.6-20091214.jar
  - poi-examples-3.6-20091214.jar
  - poi-ooxml-3.6-20091214.jar
  - poi-ooxml-schemas-3.6-20091214.jar
  - poi-scratchpad-3.6-20091214.jar
  - dom4j-1.6.1.jar
  - geronimo-stax-api_1.0_spec-1.0.jar
  - commons-logging-1.1.jar
  - xmlbeans-2.3.0.jar
  - junit-3.8.1.jar
  - log4j-1.2.3.jar

and the error message is the same one as before.

There is a note in the maven artifacts section that may apply to my case:

"poi-ooxml requires poi-ooxml-schemas. This is a substantially smaller 
version of the ooxml-schemas-1.0.jar. The larger ooxml-schemas jar is 
only required for development. "

Could this be the nature of my run-time problem?

Where can I find "the larger ooxml-schemas jar"?

TIA,

-Ramon



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@poi.apache.org
For additional commands, e-mail: user-help@poi.apache.org


Mime
View raw message