poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Burch <n...@torchbox.com>
Subject Re: XSSFWorkbook create fails with xmlbeans exception?
Date Mon, 26 Oct 2009 11:45:28 GMT
On Sun, 25 Oct 2009, Aaron Zeckoski wrote:
> Caused by: org.apache.xmlbeans.SchemaTypeLoaderException: XML-BEANS
> compiled schema: Incompatible minor version - expecting up to 23, got
> 24 (schemaorg_apache_xmlbeans.system.sE130CAA0A01A7CDE5A2B4FEB8B311707.index)
> - code 3

Looks like you have two different versions of XmlBeans on your classpath. 
The compiled schemas that POI uses are compiled with XmlBeans 2.3. That 
means that when you run, you need to have the xmlbeans runtime of 2.3 or 
later present (currently that'll mean 2.3, 2.4 or svn) - newer runtimes 
can run older schemas, but not the other way around. It looks to me like 
you have an older version of xmlbeans that's taking priority

Nick

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@poi.apache.org
For additional commands, e-mail: user-help@poi.apache.org


Mime
View raw message