poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From postmas...@schmoecker.de
Subject Problem building BAT-Array from XBAT-Blocks
Date Mon, 27 Dec 2004 14:07:35 GMT
I created a quite simple but large EXCEL-File with EXCEL2000 with a size of about 
35MB.  This file uses 4 XBAT-Blocks.
When building the BAT-array from these XBAT-blocks I encountered a problem ( which 
arose the moment more then 1 XBAT-Blocks was needed ).
It seems as if not all 128 integers in the block were holding indices of BAT-blocks but 
only the first 127 of them.  The last integer ( at offset +1FC ) pointed to the next XBAT-
Block.   The same was true for the other XBAT-blocks as well.
Thus the last integers of all XBAT-blocks formed a chain just like the one found in the 
BAT-Array with the last XBAT-Block having -2 as end-indicator while the other integers 
of all these blocks formed the extension of the BAT-Array.

Can anyone confirm the behavior mentionend above or is this an error on my side?

If the previous were true, then the XBAT-Blocks would not necessarily have to be 
located in sequence as described in the documentation here

http://jakarta.apache.org/poi/poifs/fileformat.html

and the BAT-Array is only extended by 127 of the 128 integers in each XBAT-block.



live long and prosper
Stefan Schmöcker


---------------------------------------------------------------------
To unsubscribe, e-mail: poi-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: poi-user-help@jakarta.apache.org


Mime
View raw message