poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sanabria, Javier (GE Energy, Non GE)" <javier.sanab...@ps.ge.com>
Subject Problem with POI
Date Wed, 27 Oct 2004 18:09:11 GMT
Hi...

I have the following process in a web application: My users needs to
download some templates (excel files) from a web site. They have to select
the project number and click on download button and my application basically
get a empty template (excel file) from the server and fill it with the
project's data and finally send it by email (using SMTP).

I have the web application (jsp, servlets) installed local on my computer
(Win 2000, Office 2000); it uses Weblogic 6.1 sp1 as a web application
server. Also, I'm using POI 2.5.1. The template is a sample excel workbook
with a simple sheet in. It does not have drop downs or other objects just
text and color in some cells.

The application works perfect locally, I got the files into the email and I
can open them..... But.... when I do a WAR file of my application to deploy
it in Production environment, I got email with attachments, but when I try
open excel file attached I got: AN ERROR OCCURRED INITIALIZING THE VBA
LIBRARIES (2). and I can not open the file

The server on Production environment is SUN with Solaris as O/S Using
weblogic 6.1 sp 1.

Could any one of you, help me to find out why the same code works in local
environment and the same does not work in production environment?



	Javier Perez Sanabria


---------------------------------------------------------------------
To unsubscribe, e-mail: poi-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: poi-user-help@jakarta.apache.org


Mime
View raw message