poi-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom <tomcat...@yahoo.es>
Subject What JDK version I must use?
Date Fri, 16 Jan 2004 08:22:50 GMT
Hi,

I do POI/HSSF programming in WNT using eclipse. In
this environment I can compile and execute POI/HSSF
porgrams without problem.

But when I try in the real machine (HP-UX) I can't
compile POI/HSSF code and always get the same message:

[sisint]/partes:$javac -classpath
$CLASSPATH:../lib/poi.jar ProvaExcel.java
error: Invalid class file format:
../lib/poi.jar(org/apache/poi/hssf/usermodel/H
SSFWorkbook.class), wrong version: 46, expected 45
ProvaExcel.java:5: Class
org.apache.poi.hssf.usermodel.HSSFWorkbook not found
in
 import.
import org.apache.poi.hssf.usermodel.HSSFWorkbook;
       ^
2 errors  

Perhaps, it is I am using and older version of JDK. 

[XXXXX]:$java -version
java version "HP-UX Java C.01.17.00 99/02/08" 

I try find the minimum JDK version for POI in the web
but i can't find :·(

Thanks a lot for reading this mail and help me.

Regards,

Xevi.


___________________________________________________
Yahoo! Messenger - Nueva versión GRATIS
Super Webcam, voz, caritas animadas, y más...
http://messenger.yahoo.es

---------------------------------------------------------------------
To unsubscribe, e-mail: poi-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: poi-user-help@jakarta.apache.org


Mime
View raw message