poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 61490] New: In a particular document, the cell is missing
Date Tue, 05 Sep 2017 08:42:46 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=61490

            Bug ID: 61490
           Summary: In a particular document, the cell is missing
           Product: POI
           Version: 3.16-FINAL
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: HWPF
          Assignee: dev@poi.apache.org
          Reporter: chenyu_eagle@aliyun.com
  Target Milestone: ---

Created attachment 35292
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=35292&action=edit
the test code and .doc file

Sorry for my poor english
I'm using Google Translate

I uploaded my test code and test files, see attachment

In this particular case of attachment

   table.numRows() return  4  (actually, it should be 3)

  and the  row.numCells()  at row[2] ,return 2 

  so, the last cell of table (cell value is  33) is missing

But, 
  if you insert a space or whatever character before the last cell of table , 
  then correct !

I tested 3.16 and 3.17-beta1, same results

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message