poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 60571] Custom number formats with custom currency symbols not applied to cells
Date Wed, 25 Jan 2017 22:29:39 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=60571

--- Comment #8 from Jonny <jlwinger@us.ibm.com> ---
(In reply to Greg Woolsey from comment #7)
> I tried to figure that out about 6 years ago, and got nowhere.  I didn't
> prove it couldn't be done, but I did convince myself that Excel was too
> tightly integrated with Windows for that particular purpose to make it easy.
> Even if you could embed something that Excel actually paid attention to, I'm
> not sure it would be applied consistently either, and may cause a confusing
> user experience, especially for users with different regional settings.
> 
> You might be better off formatting things explicitly and converting cells to
> text, although that won't work if they are needed for formulas elsewhere.

Ah yes, there could be aggregates on these values. Thank you for your help! I
remember that for html files in excel, you can add  style attribute with
mso-number-format="...". From looking at the xml, I'm not quite certain yet,
but I take it that it's not possible to use that attribute in the sheet.xml?

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message