poi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 59933] New: IllegalAccessError POILogger.log
Date Wed, 03 Aug 2016 09:37:13 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=59933

            Bug ID: 59933
           Summary: IllegalAccessError POILogger.log
           Product: POI
           Version: 3.14-FINAL
          Hardware: PC
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: POI Overall
          Assignee: dev@poi.apache.org
          Reporter: a.niemeyer@euroimmun.de

Hi!

Since version 3.13 there is an issue with the logger and the changed POILogger: 

Whenever in the DocumentHelper class in the method trySetXercesSecurityManager
and within the catch block (line 84) the logger is called, an
IllegalAccessError is thrown by the logger instance call: 

logger.log(POILogger.WARN, "SAX Security Manager could not be setup", t);

Exception: 
java.lang.IllegalAccessError: tried to access method
org.apache.poi.util.POILogger.log(ILjava/lang/Object;Ljava/lang/Throwable;)V
from class org.apache.poi.util.DocumentHelper

This happens always if a xlsx workbook is contructed. 

When some of you fix this in the POILogger, please also change the order of
SecurityManager whereas the in a server environment (e.g. JEE and JBoss) the
org.apache.xerces.util.SecurityManager might probably more often in use: 

Should be: 

 "org.apache.xerces.util.SecurityManager"
 "com.sun.org.apache.xerces.internal.util.SecurityManager",

Thank you in advance,
Andreas

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


Mime
View raw message